Bug 522818 - netlabel_tools initscript is not LSB compatible
Summary: netlabel_tools initscript is not LSB compatible
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: netlabel_tools
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: InitScriptsProject 537053
TreeView+ depends on / blocked
 
Reported: 2009-09-11 15:58 UTC by Miroslav Vadkerti
Modified: 2010-07-13 07:49 UTC (History)
3 users (show)

Fixed In Version: netlabel_tools-0.19-7.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 537053 (view as bug list)
Environment:
Last Closed: 2010-07-13 07:49:41 UTC


Attachments (Terms of Use)

Description Miroslav Vadkerti 2009-09-11 15:58:59 UTC
Description of problem:
According to https://fedoraproject.org/wiki/FCNewInit/Initscripts there are
several issues with netlabel_tools initscript:

PROBLEM 1:
Mandatory parameter force-reload not implemented

PROBLEM 2:
Status after succesfully started (or condrestart) netlabel service returns 1, expected 0

PROBLEM 3:
Status after stopping netlabel service is 7, expected 3

PROBLEM 4:
Status after lock file exists is 1, expected 2

Version-Release number of selected component (if applicable):
netlabel_tools-0.19-3.fc12

How reproducible:
always

Steps to Reproduce:
PROBLEM 1:
 1. service netlabel force-reload

 Actual results:
 no implemented

 Expected result:
 Forced reload of service

PROBLEM 2:
 1. configure /etc/netlabel.rules
 2. service netlabel start (or condrestart)
 3. service netlabel status; echo $?
  
 Actual results:
 1

 Expected results:
 0

PROBLEM 3:
 1. service netlabel stop
 2. service netlabel status; echo $?

 Actual results:
 7

 Expected results:
 3

PROBLEM 4:
 1. touch /var/lock/subsys/netlabel
 2. service netlabel status; echo $?

 Actual results:
 1

 Expected results:
 2

Comment 1 Miroslav Vadkerti 2009-09-11 16:24:34 UTC
CORRECTION:

PROBLEM 1 is not an issue since netlabel doesn't start any daemon.

PROBLEM 2 expected resutl should be I think 3, as no deamon is run by the initscript

Comment 2 Peter Vrabec 2009-09-23 12:27:11 UTC
PROBLEM 2 - can't reproduce, 0 is OK imho
# service netlabel start
wrabco:/etc/init.d
# echo $?
0

PROBLEM 3 - can't reproduce, 0 is ok see 
https://fedoraproject.org/wiki/Packaging/SysVInitScript
# service netlabel stop
wrabco:/etc/init.d
# echo $?
0

PROBLEM 4: - fixed 
netlabel_tools >= 0_19-6_fc12

Comment 3 Miroslav Vadkerti 2010-02-08 08:33:32 UTC
Peter, this package was never build .. why is this bug closed?

Comment 4 Bug Zapper 2010-03-15 12:49:28 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Fedora Update System 2010-06-16 12:06:17 UTC
netlabel_tools-0.19-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/netlabel_tools-0.19-7.fc13

Comment 6 Fedora Update System 2010-06-16 17:48:05 UTC
netlabel_tools-0.19-7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update netlabel_tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/netlabel_tools-0.19-7.fc13

Comment 7 Kevin Fenzi 2010-06-30 19:14:00 UTC
I would like to note that the wiki link here is NOT AN OFFICIAL GUIDELINE. ;) 

The real guideline is: 
https://fedoraproject.org/wiki/Packaging/SysVInitScript

Comment 8 Miroslav Vadkerti 2010-07-08 11:19:40 UTC
VERIFIED as fixed in netlabel_tools-0.19-7.fc13

Comment 9 Fedora Update System 2010-07-13 07:49:36 UTC
netlabel_tools-0.19-7.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.