Bug 522842 - Multihead fails on GeForce Go 7600
Summary: Multihead fails on GeForce Go 7600
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-11 17:59 UTC by Ondrej Zary
Modified: 2009-09-13 21:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-13 21:58:05 UTC


Attachments (Terms of Use)
X log (66.93 KB, text/plain)
2009-09-11 17:59 UTC, Ondrej Zary
no flags Details

Description Ondrej Zary 2009-09-11 17:59:42 UTC
Created attachment 360711 [details]
X log

Description of problem:
Two monitors do not work properly on Pavilion dv9000 laptop. When enabing mirror mode in gnome-display-properties, it crashes:
display-properties:ERROR:xrandr-capplet.c:551:rebuild_resolution_combo: code should not be reached

Changing resolution and enabling/disabling monitors seems to work for a while but crashes after a while (either X server hangs or crashes).

Version-Release number of selected component (if applicable):
from Fedora Test Day 20090908 Live CD

How reproducible:
Always

Steps to Reproduce:
1. Boot the Live CD with two monitors
2. Enable mirror mode, turn on/off monitors, change resolution in gnome-display-properties
  
Actual results:
gnome-display-properties crashes or entire X server crashes

Expected results:
Nothing should crash.

Additional info:
http://www.smolts.org/client/show/pub_5ae58938-8cb5-4de7-abb0-856e895310ee

Comment 1 Ben Skeggs 2009-09-11 23:25:27 UTC
The first issue mentioned is likely a bug in g-d-p, but just in case are you able to post the output of xrandr --verbose to make sure we report sane info.

The hang/crash issue has been fixed already, if you can grab http://koji.fedoraproject.org/koji/buildinfo?buildID=131379 then you should be fine!

Thanks!

Comment 2 Ondrej Zary 2009-09-13 18:01:50 UTC
Yes, that seems to be gnome-desktop-properties bug. Looks like it crashes when enabling mirror mode but the connected monitors do not have any common resolution - which is typical for a wide screen laptop LCD and any external monitor.

xrandr output looks correct:
Screen 0: minimum 320 x 200, current 2840 x 1050, maximum 4096 x 4096
LVDS-0 connected 1440x900+0+0 (normal left inverted right x axis y axis) 367mm x 230mm
   1440x900       59.9*+
VGA-0 connected 1400x1050+1440+0 (normal left inverted right x axis y axis) 408mm x 300mm
   1400x1050      60.0*+
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
DVI-D-0 disconnected (normal left inverted right x axis y axis)


I confirm that this new version of nouveau fixes the crash problem. I can now change resolutions and turn monitors on/off and it does not crash anymore.

Comment 3 Ben Skeggs 2009-09-13 21:58:05 UTC
With the next kernel version that'll hit rawhide, nouveau will add some additional modes for laptop panels which should allow you to do mirror mode fine so I'll close this as fixed.

Thanks!


Note You need to log in before you can comment on or make changes to this bug.