Bug 52285 - PPPD dies with error 53 or 9 or 5
PPPD dies with error 53 or 9 or 5
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-22 08:43 EDT by Jean Redelinghuys
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 05:29:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jean Redelinghuys 2001-08-22 08:43:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)

Description of problem:
pppd dies ever so often with a error 53 ect
when I try to connect to my isp with a ifup ppp0 command
Sometimes it also hangs the shell to such a extent that I have to kill
the shell get rid of it

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.configure ppp interface from kde
2.type ifup ppp0 at prompt or in shell script
3.
	

Actual Results:  sometimes the shell will hang or pppd will report a error 
53 or 9 or 5

Expected Results:  the shell sould have returned to the prompt or the rest 
of the shell script should have executed

Additional info:

the script that I am trying to use are as follows

#!/bin/bash
/sbin/ifup ppp0
sleep 5
fetchmail -d0 -v --nosyslog
sleep 5
/usr/sbin/sendmail -q
sleep 2
/sbin/ifdown ppp0
Comment 1 Denis Hruza 2001-09-25 15:57:36 EDT
I just updated from 7.0 to 7.1 (with latest updates) and i'm getting the same
thing. There quite a few bug reports that also look like they are
related...going back to 2-2001
(bugzilla search ppp and initscripts)

What appears to happen is that ppp-watch is hanging and complaining about not
finding /var/run/ppp-ppp0.pid and other goofyness.
I downloaded the source for both initscripts and ppp so I could look at the
source and see what going on and to find out what the errpr codes were.

It will dial, connect and then kill itself. One of the workarounds includes
editing 'cfgup-ppp' and commenting out

#  exec /sbin/ppp-watch "${DEVICE}" "$@"

..and then letting the exec pppd line at the bottom fire it up. This also
requires an edit which is to remove the leading '-' from the updetach option

#exec /usr/sbin/pppd -updetach $opts ${MODEMPORT} ${LINESPEED} \
exec /usr/sbin/pppd $opts ${MODEMPORT} ${LINESPEED} \
    ipparam ${DEVNAME} linkname ${DEVNAME} call ${DEVNAME}\
    noauth \
    ${PPPOPTIONS}

which resolves the 
"/usr/sbin/pppd: unrecognized option '-updetach'"
problem. This does not correct the fact you can no longer run ppp-watch having a
reconnect on failure setup or bring up ppp0 at boot time

This machine had a working setup that I had been using for years. I moved my
files aside and let rp3 create new ones and the problem persisted.
If I uncomment the 'exec /sbin/ppp-watch' line now that I have it rigged it will
it will go back to hanging/failing.

For now I have a cron looking for pppd and restarting it.

#!/bin/ksh
/bin/ps cuax | /bin/grep ' pppd'
result="$?"
if [ $result == "1" ]; then
        print "Not found..starting pppd";
        /etc/sysconfig/network-scripts/ifup-ppp ppp0 &
else
        print "Started pppd"
fi

----------------
Version-Release number of selected component (if applicable):
7.1 with all updates
initscripts-5.84-1
ppp-2.4.0-2----------------
Comment 2 Denis Hruza 2001-09-25 16:24:31 EDT
I made a mistake in my report

The default line in ipup-ppp is:

exec /usr/sbin/pppd -detach $opts ${MODEMPORT} ${LINESPEED} \
    ipparam ${DEVNAME} linkname ${DEVNAME} call ${DEVNAME}\
    noauth \
    ${PPPOPTIONS}

I changed '-detach' to 'updetach':

exec /usr/sbin/pppd updetach $opts ${MODEMPORT} ${LINESPEED} \
    ipparam ${DEVNAME} linkname ${DEVNAME} call ${DEVNAME}\
    noauth \
    ${PPPOPTIONS}

...in order for it to detach and work properly for me while having the 'exec
/sbin/ppp-watch' line commented out.
Otherwise 'ifup-ppp ppp0' hangs and ctrl-c kills the connection.

Sorry about that.
Comment 3 Thomas Woerner 2004-08-13 05:29:45 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or Fedora
Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.

Note You need to log in before you can comment on or make changes to this bug.