Bug 52288 - up2date requires GPG key for --configure
up2date requires GPG key for --configure
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: uopvybqq
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-22 09:59 EDT by Sean Dilda
Modified: 2015-01-07 18:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-14 09:01:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Dilda 2001-08-22 09:59:11 EDT
When running up2date in --configure mode, it prompts you to install the GPG
key if you have the GPG option turned on.  This seems to be something that
isn't needed for going into the configure mode, especially as one of the
configure options is to not use the GPG key.

This means that in order to turn off use of the GPG key, you have to either
have the key, or run configure with the --nosig option, which seems like an
unneeded annoyance.
Comment 1 Glen Foster 2001-08-22 18:10:49 EDT
This defect is considered SHOULD-FIX for Fairfax.
Comment 2 Adrian Likins 2001-08-24 15:09:03 EDT
hmm, wacky. 

Well, you really _should_ use the gpg key, and you will _always_ have it,
and there isnt really any need for this on non-beta cycles. But alas...


Moved the gpg check till after the configure stuff, and broke out the
root check to run it first. Should fix this circumstance.

Note that this is pretty much another "beta-only" bug...
Comment 3 Adrian Likins 2001-08-24 15:12:00 EDT
should be fixed in cvs now...
Comment 4 Jay Turner 2003-02-14 09:01:56 EST
Fix confirmed with up2date-3.1.15-7.

Note You need to log in before you can comment on or make changes to this bug.