Bug 522888 - net-tools initscript is not LSB compliant
Summary: net-tools initscript is not LSB compliant
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: net-tools
Version: 12
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jiri Popelka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: InitScriptsProject 537322
TreeView+ depends on / blocked
 
Reported: 2009-09-11 23:25 UTC by Miroslav Vadkerti
Modified: 2009-11-25 15:31 UTC (History)
2 users (show)

Fixed In Version: 1.60-99.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 537322 (view as bug list)
Environment:
Last Closed: 2009-11-25 15:31:24 UTC


Attachments (Terms of Use)

Description Miroslav Vadkerti 2009-09-11 23:25:32 UTC
Description of problem:
According to https://fedoraproject.org/wiki/FCNewInit/Initscripts there are
several issues with netplugd initscript:

PROBLEM 1:
Mandatory option force-reload not implemented

PROBLEM 2:
Usage doesn't show condrestart option (and force-download because of PROBLEM 1)

PROBLEM 3:
After condrestart the status of initscript returns 1, expected 0

Version-Release number of selected component (if applicable):
net-tools-1.60-95.fc12

How reproducible:
always

Steps to Reproduce:
PROBLEM 1:
 1. service netplugd force-reload
  
 Actual results:
 Not implemented

 Expected results:
 Option implemented


PROBLEM 3:
 1. service netplugd condrestart
 2. service netplugd status; echo $?

 Actual results:
 1

 Expected results:
 0

Comment 1 Miroslav Vadkerti 2009-11-10 16:31:02 UTC
Hi Jiri,

when can I expect a package with fix regarding this issue?

Thanks,
Miro

Comment 2 Miroslav Vadkerti 2009-11-10 16:31:42 UTC
What other inforamtion is needed?

Comment 3 Jiri Popelka 2009-11-11 06:07:26 UTC
You can try one of these
http://koji.fedoraproject.org/koji/buildinfo?buildID=140598

Comment 4 Fedora Update System 2009-11-11 14:59:14 UTC
net-tools-1.60-98.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update net-tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11140

Comment 5 Miroslav Vadkerti 2009-11-12 19:14:08 UTC
VERIFIED as fixed in net-tools-1.60-98.fc12

Comment 6 Fedora Update System 2009-11-16 07:27:02 UTC
net-tools-1.60-99.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update net-tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11140

Comment 7 Fedora Update System 2009-11-25 15:31:15 UTC
net-tools-1.60-99.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.