Bug 522901 - Sep 10 xorg-x11 updates broken hal support
Summary: Sep 10 xorg-x11 updates broken hal support
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-12 03:25 UTC by Mithun Bhattacharya
Modified: 2018-04-11 13:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:36:43 UTC


Attachments (Terms of Use)
Current working xorg.conf (400 bytes, application/octet-stream)
2009-09-12 03:25 UTC, Mithun Bhattacharya
no flags Details

Description Mithun Bhattacharya 2009-09-12 03:25:08 UTC
Created attachment 360751 [details]
Current working xorg.conf

Description of problem:
After running yum update I received the following xorg files
Sep 10 20:17:07 Updated: xorg-x11-server-utils-7.4-7.1.fc11.x86_64
Sep 10 20:17:10 Updated: xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64
Sep 10 20:17:10 Updated: xorg-x11-drv-evdev-2.2.5-1.fc11.x86_64
Sep 10 20:17:10 Updated: xorg-x11-drv-fpit-1.3.0-3.fc11.x86_64

Till this point I was using a custom xorg.conf which added the following 
Option "AutoAddDevices" "off"
Driver         "nvidia"

I also have synaptic.fdi from
https://bugzilla.redhat.com/attachment.cgi?id=312620 and x11-input.fdi from 
http://cgit.freedesktop.org/xorg/xserver/tree/config/x11-input.fdi
installed in /etc/hal/fdi/policy/

This configuration has worked fine for me since Oct 10, 2008 when FC9 broke the Synaptic Touchbpad support.

As of now the only way for me to use my xorg.conf is to comment out the AutoAddDevices Off option.

Running a bare X from the command prompt causes a segfault with the option enabled.

How reproducible: Always

Actual results:


Expected results: gdm & startx should run as expected.


Additional info: I am attaching my current working xorg.conf - just enabling the AutoAddDevices Off option in the file crashes X.

Comment 1 Matěj Cepl 2009-11-05 18:37:56 UTC
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]

Comment 2 Mithun Bhattacharya 2009-11-06 04:22:07 UTC
My desktop is updated as of Thu Nov  5 22:20:11 CST 2009 and I can confirm with the configuration entry enabled and the two fdi files in the policy folder my X still doesn't startup.

I will download the FC12 live CD and check it out later in the night and revert on the status.

Comment 3 Bug Zapper 2010-04-28 10:18:40 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Bug Zapper 2010-06-28 14:36:43 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.