Bug 522929 - Occasional system hang when KMS kicks in (RV770)
Occasional system hang when KMS kicks in (RV770)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
card_R700/M
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-12 05:29 EDT by Nicolas Mailhot
Modified: 2013-01-10 00:28 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-04 05:07:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (192.90 KB, text/plain)
2009-09-12 05:29 EDT, Nicolas Mailhot
no flags Details
A typical dmesg, before the problem (56.84 KB, text/plain)
2009-09-12 05:32 EDT, Nicolas Mailhot
no flags Details
A typical xorg log, before the problem (74.33 KB, text/plain)
2009-09-12 05:33 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2009-09-12 05:29:01 EDT
since about the time the radeon kms changes have landed in rawhide I'm getting repeated system crashes. The screen goes blank and the system does not respond anymore (the shutdown button that initiates a software shutdown via acpi does not work anymore, though it usually responds for most oops)

The hang is so fast nothing is logged in syslog or Xorg.log

Why I think this is radeon related:  it only happens with someone doing stuff in the gui, never in console or when using the system services (such as webmail)
Comment 1 Nicolas Mailhot 2009-09-12 05:29:46 EDT
Created attachment 360768 [details]
lspci
Comment 2 Nicolas Mailhot 2009-09-12 05:32:26 EDT
Created attachment 360769 [details]
A typical dmesg, before the problem
Comment 3 Nicolas Mailhot 2009-09-12 05:33:29 EDT
Created attachment 360770 [details]
A typical xorg log, before the problem
Comment 4 Nicolas Mailhot 2009-09-12 05:36:46 EDT
> someone doing stuff in the gui, 

"doing stuff" is most often scrolling fast via the wheel in firefox or some other app that displays lots of information
Comment 5 Nicolas Mailhot 2009-09-12 15:39:31 EDT
or maybe this is linked with

http://marc.info/?l=linux-kernel&m=125274202707893&w=2

Since there are no errors logged at all, it's difficult to tell
Comment 6 Jesse Keating 2009-10-21 19:13:41 EDT
Is this still happening?
Comment 7 Bruno Wolff III 2009-10-21 20:34:11 EDT
I still see crashes fairly often with my rv280. I also occasionally get X restarts. With my rv530 I haven't seen any crashes lately, but get an occasional X restart (though I don't think I have seen one of those for over a week now). On the machine with the rv280 I am also running a third party kernel driver for some telephony hardware and had been having crashes that seemed to be related to an audio driver. But the frequency of crashes went way up after going from F11 to F12 and using KMS. Also what may or may not be related is if I go to a vt screen, when I go back to the X session the screen is black and so far my recourse has been to restart it with telinit.
Comment 8 Nicolas Mailhot 2009-10-22 03:36:30 EDT
My gfx problems have been reduced to the system hanging up in boot at KMS mode-switch time (irregularly, I suppose that means a race or timing problem somewhere in dracut)
Comment 9 Adam Williamson 2009-10-23 16:54:48 EDT
Bruno, can you please file a separate bug for your rv280 issue, including as much information as you can from the bug filing guide? https://fedoraproject.org/wiki/How_to_debug_Xorg_problems . I doubt your issue is the same as Nicolas' .

Nicolas, is there any kind of information you can get from the KMS failure? How often does it happen?

Hardware is a (--) PCI:*(0:1:0:0) 1002:9442:174b:e810 ATI Technologies Inc RV770 [Radeon HD 4850] , btw.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Nicolas Mailhot 2009-10-24 04:53:19 EDT
(In reply to comment #9)

> Nicolas, is there any kind of information you can get from the KMS failure?

Not really, this is in a very early boot phase, and as a result of the mode switch I get a blank screen with no info on it at all

> How often does it happen?

Fairly open or I wouldn't have bothered to open the bug. Now rebooting rawhide is very bad for my blood pressure, so I try to avoid it as much as possible (when xorg crashed the system at it did before, I rebooted many times a day, now I reboot maybe once every other week).

I'd be tempted to say it hangs every time and you need several attempts to boot the system, but I don't think I would remember a simple successful reboot, so it's probably not the case.

I never had this problem before KMS
Comment 11 Adam Williamson 2009-10-30 17:12:01 EDT
This was discussed at the blocker bug review today. As it seems to be a single-system bug - we can find no other reports of exactly this issue - and nomodeset is a sufficient workaround, we agreed not to consider it a blocker bug.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Adam Williamson 2009-11-01 17:33:44 EST
Jerome, you indicated in 528593 that this may well be a dupe of that bug, but the hardware is somewhat different: this is r700+ICH10, whereas almost all cases in 528593 are r600+ICH9. Do you think we should close this as a dupe or keep it separate?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Jérôme Glisse 2009-11-03 15:24:05 EST
Nicolas can you test if lastest F12 kernel (-112) works for you ?
Comment 14 Adam Williamson 2009-11-03 15:34:07 EST
You can find it at http://koji.fedoraproject.org/koji/buildinfo?buildID=139511

or there's a live build here:

http://adamwill.fedorapeople.org/radeon-20091102-x86_64.iso

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Nicolas Mailhot 2009-11-03 17:01:31 EST
I chain-rebooted half a dozen time (cold and hot, being careful to wait foe gdm before rebooting to give X the chance to frob the card) and didn't hang once at the usual place

Of course since the hang was never systematic I may have been lucky but it seems fixed (or at least made a lot less frequent) to me
Comment 16 Adam Williamson 2009-11-03 17:06:37 EST
thanks a lot for testing. we can close this when kernel 112 is tagged...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Jérôme Glisse 2009-11-04 05:07:29 EST
112 is tagged if i am not wrong so closing this bug, Nicolas reopen if you rexeperience same issue.

Note You need to log in before you can comment on or make changes to this bug.