Bug 522953 - update to darcs-2.4 for ghc-6.12.1
Summary: update to darcs-2.4 for ghc-6.12.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: darcs
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 537979 555638 ghc-haskeline 558057 558058
Blocks: 555417
TreeView+ depends on / blocked
 
Reported: 2009-09-12 16:19 UTC by Jens Petersen
Modified: 2010-03-11 13:23 UTC (History)
4 users (show)

Fixed In Version: darcs-2.4-3.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-11 13:23:46 UTC
Type: ---


Attachments (Terms of Use)

Description Jens Petersen 2009-09-12 16:19:04 UTC
Description of problem:
darcs should be updated to 2.3.0 stable.
Unfortunately this requires hashed-storage and 
haskeline to be added to fedora.

Comment 1 Bug Zapper 2009-11-16 12:18:53 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Jens Petersen 2009-11-17 01:06:50 UTC
Also QuickCheck 2 for the testsuite.

Comment 3 Jens Petersen 2009-11-17 02:29:39 UTC
hashed-storage requires mmap: bug 537971.

haskeline is actually part of ghc-6.12
so may wait for that before updating darcs.
Assuming it builds with 6.12. ;)

Comment 4 Jens Petersen 2010-01-09 13:13:26 UTC
(In reply to comment #3)
> hashed-storage requires mmap: bug 537971.

mmap is now approved.

> haskeline is actually part of ghc-6.12
> so may wait for that before updating darcs.

Though ghc doesn't actually ship it... :-/

Comment 5 Jens Petersen 2010-01-15 02:28:14 UTC
I posted a ghc-html package for review.

Comment 6 Jens Petersen 2010-01-23 11:57:51 UTC
darcs-beta requires hashed-storage >= 0.4.5 which requires
binary and dataenc: adding their package reviews to depends.

Comment 7 Jens Petersen 2010-02-23 02:09:30 UTC
(noting that rc2 is now available:)

Comment 8 Jens Petersen 2010-03-04 00:37:38 UTC
*** Bug 555417 has been marked as a duplicate of this bug. ***

Comment 9 Jens Petersen 2010-03-04 00:44:24 UTC
darcs-2.4 has been built in rawhide.

http://koji.fedoraproject.org/koji/buildinfo?buildID=159541

Moving to 13 for backport.

Comment 10 Fedora Update System 2010-03-05 02:31:47 UTC
ghc-hashed-storage-0.4.7-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ghc-hashed-storage-0.4.7-1.fc13

Comment 11 Fedora Update System 2010-03-05 13:33:59 UTC
ghc-hashed-storage-0.4.7-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2010-03-08 04:54:12 UTC
darcs-2.4-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/darcs-2.4-3.fc13

Comment 13 Fedora Update System 2010-03-09 03:11:58 UTC
darcs-2.4-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update darcs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/darcs-2.4-3.fc13

Comment 14 Fedora Update System 2010-03-11 13:23:35 UTC
darcs-2.4-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.