Bug 522977 - setroubleshoot: SELinux is preventing /usr/sbin/abrtd "read" access on Bugzilla.conf.
Summary: setroubleshoot: SELinux is preventing /usr/sbin/abrtd "read" access on Bugzil...
Keywords:
Status: CLOSED DUPLICATE of bug 522878
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:c4e516390ea...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-12 22:40 UTC by Michal Schmidt
Modified: 2009-09-12 22:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-12 22:44:48 UTC


Attachments (Terms of Use)

Description Michal Schmidt 2009-09-12 22:40:38 UTC
The following was filed automatically by setroubleshoot:

Souhrn:

SELinux is preventing /usr/sbin/abrtd "read" access on Bugzilla.conf.

Podrobný popis:

[abrtd has a permissive type (abrt_t). This access was not denied.]

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Povolení přístupu:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Další informace:

Kontext zdroje                system_u:system_r:abrt_t:s0
Kontext cíle                 system_u:object_r:user_home_dir_t:s0
Objekty cíle                 Bugzilla.conf [ file ]
Zdroj                         abrtd
Cesta zdroje                  /usr/sbin/abrtd
Port                          <Neznámé>
Počítač                    (removed)
RPM balíčky zdroje          abrt-0.0.8.5-1.fc12
RPM balíčky cíle           
RPM politiky                  selinux-policy-3.6.31-3.fc12
Selinux povolen               True
Typ politiky                  targeted
MLS povoleno                  True
Vynucovací režim            Enforcing
Název zásuvného modulu     catchall
Název počítače            (removed)
Platforma                     Linux (removed) 2.6.31-2.fc12.x86_64 #1 SMP Thu Sep 10
                              00:25:40 EDT 2009 x86_64 x86_64
Počet upozornění           4
Poprvé viděno               So 12. září 2009, 23:46:14 CEST
Naposledy viděno             Ne 13. září 2009, 00:19:05 CEST
Místní ID                   709e28f8-487c-4933-b710-dcc11e2be524
Čísla řádků              

Původní zprávy auditu      

node=(removed) type=AVC msg=audit(1252793945.558:54): avc:  denied  { read } for  pid=1082 comm="abrtd" name="Bugzilla.conf" dev=dm-10 ino=153222 scontext=system_u:system_r:abrt_t:s0 tcontext=system_u:object_r:user_home_dir_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1252793945.558:54): avc:  denied  { open } for  pid=1082 comm="abrtd" name="Bugzilla.conf" dev=dm-10 ino=153222 scontext=system_u:system_r:abrt_t:s0 tcontext=system_u:object_r:user_home_dir_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1252793945.558:54): arch=c000003e syscall=2 success=yes exit=0 a0=25e3fe8 a1=0 a2=1b6 a3=4d items=0 ppid=1 pid=1082 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:abrt_t:s0 key=(null)


audit2allow suggests:

#============= abrt_t ==============
allow abrt_t user_home_dir_t:file { read open };

Comment 1 Michal Schmidt 2009-09-12 22:44:48 UTC

*** This bug has been marked as a duplicate of bug 522878 ***


Note You need to log in before you can comment on or make changes to this bug.