Bug 52302 - up2date can't resolve dependencies for libao
up2date can't resolve dependencies for libao
Status: CLOSED DUPLICATE of bug 52243
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: uopvybqq
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-22 12:39 EDT by Michael Young
Modified: 2015-01-07 18:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-22 12:39:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2001-08-22 12:39:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.6 sun4u)

Description of problem:
I am upgrading from roswell to roswell2 using up2date and packages in
several batches. However when I tried to upgrade a batch containing the
libao package, the upgrade crashed at the resolving dependency stage with
the errors below. I am using the up2date packages which resolve bug 50891 .

Traceback (innermost last):
  File "/usr/sbin/up2date", line 1017, in ?
    main()
  File "/usr/sbin/up2date", line 365, in main
    sys.exit(batchRun(argObj.getLong("list"), pkgNames, fullUpdate))
  File "/usr/sbin/up2date", line 934, in batchRun
    (depPackages, conflicts) = up2date.dryRun(selPkgList, printCallback,
percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1774, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date_client/up2date.py", line 1740, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1706, in
process_deps
    changed = self.__dependencies(dependencies)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1594, in
__dependencies
    refreshCallback = self.refreshCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 786, in solveDep
    pkg = pkgs[0]
IndexError: list index out of range

How reproducible:
Always

Steps to Reproduce:
1. up2date libao
Comment 1 Adrian Likins 2001-08-24 14:51:50 EDT
This is a combo of a broken upgrade path, and an up2date bug. Should
be fixed in the next version. See bug #52243

*** This bug has been marked as a duplicate of 52243 ***
Comment 2 Michael Young 2001-08-24 16:59:48 EDT
I can't see bug 52243, could you make it visible please?

Note You need to log in before you can comment on or make changes to this bug.