Bug 523059 - Running mock results in uncompleted transaction
Running mock results in uncompleted transaction
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-09-13 15:45 EDT by Nicolas Mailhot
Modified: 2014-01-21 01:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 09:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-09-13 15:45:00 EDT
Description of problem:

Each time I use mock lately, I get popups later in the desktop that ask to run yum-complete-transaction. When I run yum-complete-transaction I see yum replay the package installations it did for mock but in the system itself.

Since one of the main point of mock is not to have to install packages needed to build on the system itself, this is a big problem

Mock yum transactions should not be queued for replay in any case

Version-Release number of selected component (if applicable):

mock-0.9.17-3.fc12.noarch
Comment 1 seth vidal 2009-09-14 13:08:54 EDT
need a ver of yum.
Comment 2 Clark Williams 2009-09-14 14:05:16 EDT
do you see this for all configs?
Comment 3 Nicolas Mailhot 2009-09-14 14:49:20 EDT
The only config I used lately is

#!/usr/bin/python -tt
config_opts['root'] = 'fedora-development-x86_64-1'
config_opts['target_arch'] = 'x86_64'
config_opts['chroot_setup_cmd'] = 'groupinstall buildsys-build'

config_opts['yum.conf'] = """
[main]
cachedir=/var/cache/yum
debuglevel=1
reposdir=/dev/null
retries=1
obsoletes=1
timeout=10
gpgcheck=0
keepcache=0
assumeyes=1
exclude=*.i386 *.i686 *.i586 *.i486
metadata_expire=1800
#http_caching=packages
#proxy=http://192.168.1.1:8080/

# repos
[fedora-devel]
name=Fedora - Development
baseurl=http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os/
        http://download.fedora.redhat.com/pub/fedora/linux/development/x86_64/os/
#http://ftp.free.fr/mirrors/fedora.redhat.com/fedora/linux/development/$basearch/os/
enabled=1
gpgcheck=0

[koji-f12-builds]
name=Fedora - 12 - Koji builds
baseurl=http://koji.fedoraproject.org/static-repos/dist-f12-build-current/x86_64/
exclude=*debuginfo*
enabled=1
gpgcheck=0
cost=500

[koji-rawhide-builds]
name=Fedora - Devel - Koji builds
baseurl=http://koji.fedoraproject.org/static-repos/dist-rawhide-current/x86_64/
enabled=1
gpgcheck=0
cost=500
Comment 4 seth vidal 2009-09-14 16:28:56 EDT
okay - this is a yum bug - and it's directly related to the fix for 503195

I've patched it upstream. A trivial workaround is to remove the trailing / from the installroot path.
Comment 5 Bug Zapper 2010-03-15 08:49:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.