Bug 523086 - ENHANCEMENT: Article Filtering
Summary: ENHANCEMENT: Article Filtering
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepim
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-13 23:44 UTC by David Le Sage
Modified: 2009-10-02 09:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-02 09:00:28 UTC


Attachments (Terms of Use)

Description David Le Sage 2009-09-13 23:44:49 UTC
Description of problem:
*Note that this enhancement has also been submitted by myself upstream at:

http://akregator.kde.org/wiki/index.php/Talk:Suggestions/RegEx

(If you do not wish to keep a record of it here as well, please feel free to close this Bugzilla ticket.)



Akregator currently lacks filtering to enable the user to sort articles by relevancy.

Version-Release number of selected component (if applicable):
Akregator 1.5.0 (KDE 4.3.0)

How reproducible:
N/A.

Steps to Reproduce:
Two scenarios in which this functionality would be useful:


1.) Person is grabbing RSS news from an IT site each day and is pulling down a high volume of articles. However, the person only uses OSS so wants to filter for all articles containing the terms "Linux" and "Haiku", the others being ignored/sent to a trash can or whatever.


2.) Person uses Google News RSS feeds for a particular topic. Unfortunately, the ways of customising the feed provided by Google are very limited. The person may want to exclude some of the news sources provided by Google because he or she perceives they are of a lower quality or disagrees with their ideological stance. For example, Google News might be pulling the articles from the Smithtown Times, Jonestown Courier and the Williamstown Mail. The user might not like the Jonestown Courier because the articles are always sensationalised but at present he or she has no way to filter these out, either on the Google Server or via the RSS client.   


Actual results:
Functionality does not currently exist.

Expected results:
Articles that the user deems irrelevant are automatically filtered out by the RSS client.  

Additional info:

Comment 1 Steven M. Parrish 2009-10-02 09:00:28 UTC
Thanks for submitting your RFE upstream.  Going to close this for now and hope to see this enhancement in a future release.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.