Bug 523131 - krfb produces garbled display
krfb produces garbled display
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-14 04:33 EDT by Michal Hlavinka
Modified: 2009-09-18 20:15 EDT (History)
8 users (show)

See Also:
Fixed In Version: 4.3.1-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-18 20:15:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 162493 None None None Never

  None (edit)
Description Michal Hlavinka 2009-09-14 04:33:36 EDT
clone of kde bug #162493, where this problem was fixed. Please add mentioned patch to next 4.3.1 release

-----------------------------

Description of problem:
When connecting to a krfb enabled display using krdc, the display is garbled.
There are various rectangles of various colors.  Some parts of the display is
sometimes correct, but this varies when new things are drawn.

How reproducible:
always, using krdc or vncviewer on Fedora 8 and 9.

Steps to Reproduce:
1. start krfb on a machine running kde and enable uninvited connections
2. start krdc on another machine and connect to machine from point 1
3.
  
Actual results:
display is garbled

Expected results:
display looks like actual display on server
Comment 1 Rex Dieter 2009-09-14 09:36:13 EDT
looking into it...
Comment 2 Rex Dieter 2009-09-14 10:03:40 EDT
* Mon Sep 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-2
- kopete/bonjour patch
- krfb produces garbled display (#523131, kde#162493)
Comment 3 Fedora Update System 2009-09-15 10:33:36 EDT
kdenetwork-4.3.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kdenetwork-4.3.1-2.fc11
Comment 4 Fedora Update System 2009-09-15 10:34:12 EDT
kdenetwork-4.3.1-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kdenetwork-4.3.1-2.fc10
Comment 5 Fedora Update System 2009-09-16 16:35:28 EDT
kdenetwork-4.3.1-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdenetwork'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9685
Comment 6 Fedora Update System 2009-09-18 20:07:53 EDT
kdenetwork-4.3.1-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-09-18 20:15:17 EDT
kdenetwork-4.3.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.