Bug 523133 - [RHEL-6 Xen]: crons slow performance under domU
[RHEL-6 Xen]: crons slow performance under domU
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
i386 Linux
low Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On: 479661
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-14 04:37 EDT by Chris Lalancette
Modified: 2011-01-05 05:10 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 479661
Environment:
Last Closed: 2010-02-23 12:08:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lalancette 2009-09-14 04:37:38 EDT
+++ This bug was initially created as a clone of Bug #479661 +++

Hi Folks,

I have very small script for file uploading via ncftput having file size of 10KB, by manual script running it is taking around 2.x to 3 second, but under cron now it is taking above 10 second, previously when i was using Fedora-8 it works fine under cron but after upgrade to Fedora-10, it is taking time, is there any problem or is it normal, kindly advice pls.

Thanks,
Noman

--- Additional comment from mmaslano@redhat.com on 2009-01-13 05:20:26 EDT ---

Hello,
I was trying upload small tar file and measuring the time:
time ncftpput -u marca -p password computer /home/marca /home/marca/Development/PERL/perl/devel/perl-5.10.0.tar.gz
This gives different numbers in cronie: 
real    0m0.148s
user    0m0.003s
sys     0m0.012s

real    0m0.141s
user    0m0.001s
sys     0m0.015s

real    0m0.110s
user    0m0.003s
sys     0m0.018s

and in vixie-cron:
real    0m0.146s
user    0m0.001s
sys     0m0.025s

real    0m0.116s
user    0m0.002s
sys     0m0.019s

and on command line:
real    0m0.136s
user    0m0.000s
sys     0m0.015s

real    0m0.094s
user    0m0.001s
sys     0m0.015s

As you can see the time is changing, but I can't say it was slower for cronie in F-10. I didn't notice such problems with different scripts, which I'm using. Could it be your broadband or problem with ncftpput?

--- Additional comment from normanntp@gmail.com on 2009-01-13 06:03:01 EDT ---

Hi Marcela,

Thanks for your kind reply, My cron will run after every ten minute. That is not broadband connection, there are two data centers involve in that, i have one server at iweb technology that is virtual machine of xen guest of Fedora-10, and destination side i have Sago.net also another virtual machine of Fedora-10, that same script is running fine under Fedora-8 of those virtual machines of xen, but after upgradation its taking 9+second to upload a file, where in Fedora-8 same script was taking around 2-3 second to upload a 10KB file..

I am waiting for your kind swift reply.

Thanks,
Noman

--- Additional comment from mmaslano@redhat.com on 2009-01-13 10:02:00 EDT ---

I'll install virtual machine and try to test it again. I don't see any reason, why cron should prolong the upload.

--- Additional comment from mmaslano@redhat.com on 2009-01-14 04:49:15 EDT ---

I've tested your use case on my virtual machine (qemu). I can't reproduce it here.

I'm reassigning this to xen-maitainers, if they have any thoughts what's wrong. There's no obvious reason how could cron slow down the performance.

--- Additional comment from stuart@gathman.org on 2009-05-13 21:39:57 EDT ---

I've seen this before in Dom-U's running Centos4 and 5.  What happens is that normally, the clock on domU is slaved to dom0.  Occasionally, the clock on domU somehow gets out of sync, and the domU waits a very long time on things that are timed.  The simple test for this case is to run "sleep 1" from the command line.  If the clock problem is active, the sleep won't finish for a very long time.
Comment 2 RHEL Product and Program Management 2009-09-14 04:49:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Paolo Bonzini 2010-02-23 12:08:46 EST
This is basically a request for a paravirtualized clock.  As such it belongs in dom0 and/or hypervisor (see bug 222973).
Comment 4 Chris Lalancette 2010-07-19 09:32:35 EDT
Clearing out old flags for reporting purposes.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.