This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 523145 - improve debuginfo-install's error handling for yum and other exceptions
improve debuginfo-install's error handling for yum and other exceptions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-14 05:00 EDT by Michal Nowak
Modified: 2014-01-21 18:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 09:14:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-09-14 05:00:28 EDT
Description of problem:

When bug 523140 is trigged, but via debuginfo-installit spits this horrible traceback:

newman abrt-root $ sudo debuginfo-install totem
rpmdb: Thread/process 25047/3087275712 failed: Thread died in Berkeley DB library
error: db4 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 -  (-30974)
error: cannot open Packages database in /var/lib/rpm
/usr/lib/python2.6/site-packages/yum/config.py:894: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  raise Errors.YumBaseError("Error: " + e.message)
Traceback (most recent call last):
  File "/usr/bin/debuginfo-install", line 145, in <module>
    util = DebugInfoInstall()
  File "/usr/bin/debuginfo-install", line 46, in __init__
    self.main()
  File "/usr/bin/debuginfo-install", line 50, in main
    opts = self.doUtilConfigSetup()
  File "/usr/share/yum-cli/utils.py", line 84, in doUtilConfigSetup
    self.conf
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 705, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 242, in _getConfig
    startupconf = config.readStartupConfig(fn, root)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 798, in readStartupConfig
    startupconf.releasever = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File "/usr/lib/python2.6/site-packages/yum/config.py", line 894, in _getsysver
    raise Errors.YumBaseError("Error: " + e.message)
yum.Errors.YumBaseError: Error: rpmdb open failed


Can it be shaped in some way to one line error msg?

Version-Release number of selected component (if applicable):

yum-3.2.24-3.fc12.noarch
rpm-4.7.1-4.fc12.i686
yum-utils-1.1.23-3.fc12.noarch
Comment 1 seth vidal 2009-09-16 08:13:28 EDT
Same root cause has been fixed in 523140. However, having debuginfo-install do a better job catching errors is still on the list.
Comment 2 Bug Zapper 2009-11-16 07:21:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Tim Lauridsen 2010-04-30 09:14:28 EDT
YumBaseError catching was fixed in yum-3.2.26.

Note You need to log in before you can comment on or make changes to this bug.