Bug 523154 - timeout with physical cdrom on a PV guest
Summary: timeout with physical cdrom on a PV guest
Keywords:
Status: CLOSED DUPLICATE of bug 523630
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 09:14 UTC by Paolo Bonzini
Modified: 2011-01-05 10:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 506899
Environment:
Last Closed: 2009-10-02 15:30:34 UTC


Attachments (Terms of Use)

Description Paolo Bonzini 2009-09-14 09:14:25 UTC
+++ This bug was initially created as a clone of Bug #506899 +++

Description of problem:
With a line like

disk = ['tap:aio:/....,xvda,w', 'phy:/dev/cdrom,hdc:cdrom,r' ]

in the Xen configuration and no physical CDROM in the tray, the PV guest will wait for the 300 seconds timeout to occur

Version-Release number of selected component (if applicable):
5.4

How reproducible:
Add the 'phy:/dev/cdrom,hdc:cdrom,r' item to an existing PV configuration and start the VM.
  
Actual results:
300 seconds timeout

Expected results:
No timeout.

Additional info:
The bug is probably due to the device being Closed (as shown by the timeout message) but not ready.  The configuration is quite bogus, but this is a regression and, if my diagnosis is right, the fix should be easy and safe.

--- Additional comment from berrange@redhat.com on 2009-06-19 06:38:38 EDT ---

Is this really a regression - have you verified that this works in RHEL-5.3 ?  
I'm surprised if this has ever worked, since AFAIK the Xen version RHEL5 is based on has never supported CDROM devices for paravirt guests. It was only added later when Solaris paravirt support CDROm devices. 

That all said, timeouts are always the wrong answer to unsupported features - there should be explicit error message given back where required. In this case though, since the host does not really know whether the guest supports CDROM or not, it would have to attach it anyway and just hope the guest knows what todo with it.

--- Additional comment from pbonzini@redhat.com on 2009-06-19 07:04:41 EDT ---

The regression is that it takes 300 seconds instead of 10 to boot.  The configuration is bogus indeed.

--- Additional comment from berrange@redhat.com on 2009-06-19 07:10:20 EDT ---

The fact that the length of the timeout changed does not really make this is regression. It was broken before & it is still broken now.

Comment 2 RHEL Product and Program Management 2009-09-14 09:56:46 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Andrew Jones 2009-10-02 15:30:34 UTC
Bug 523630 -  [RHEL6 Xen]: Forward port 5 minute timeout for device connection was created and used for the same bug. Closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 523630 ***


Note You need to log in before you can comment on or make changes to this bug.