Bug 523164 - livecd-creator can't unmount and checking mounted filesystem
Summary: livecd-creator can't unmount and checking mounted filesystem
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: livecd-tools
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 523436
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 09:39 UTC by Pavel Alexeev
Modified: 2009-10-08 19:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-07 01:49:29 UTC
Type: ---


Attachments (Terms of Use)

Description Pavel Alexeev 2009-09-14 09:39:33 UTC
[snip]
  Installing: fedora-screensaver-theme     ################### [1023/1024] 
  Installing: gnome-bluetooth-libs         ################### [1024/1024] 

umount: /home/pasha/temp/Fedora-korda/tmp/imgcreate-qrECIn/install_root: device is busy.
        (In some cases useful info about processes that use
         the device is found by lsof(8) or fuser(1))
ioctl: LOOP_CLR_FD: Устройство или ресурс занято
umount: /home/pasha/temp/Fedora-korda/tmp/imgcreate-qrECIn/install_root: device is busy.
        (In some cases useful info about processes that use
         the device is found by lsof(8) or fuser(1))
e2fsck 1.41.4 (27-Jan-2009)
Korda-Fedora-Liv: recovering journal
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information

Korda-Fedora-Liv: ***** FILE SYSTEM WAS MODIFIED *****
[snip]

Off course on the end of this process it is failed:

[snip]
Korda-Fedora-Liv: ***** FILE SYSTEM WAS MODIFIED *****
Korda-Fedora-Liv: 98634/172032 files (0.3% non-contiguous), 610050/688128 blocks
/usr/lib/python2.6/site-packages/imgcreate/errors.py:45: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  return unicode(self.message)
Error creating Live CD : fsck returned an error!
umount: /home/pasha/temp/Fedora-korda/tmp/imgcreate-qrECIn/install_root: device is busy.
        (In some cases useful info about processes that use
         the device is found by lsof(8) or fuser(1))


Version-Release number of selected component (if applicable):
$ rpm -q livecd-tools
livecd-tools-024-1.fc11.i586


How reproducible:
Always

Comment 1 Jeremy Katz 2009-09-14 23:38:44 UTC
Usually this is caused by a package you're installing running and not allowing the filesystem to be unmounted.  If you use fuser when it fails, you should see the process that's running still

We've made it in the future that the failure to unmount is fatal and stops the rest of the process there which should be a little bit more obvious, but we can't really do anything about fixing the %post of the packages you're installing :)

Comment 2 Pavel Alexeev 2009-09-15 07:49:18 UTC
(In reply to comment #1)
> Usually this is caused by a package you're installing running and not allowing
> the filesystem to be unmounted.
What mean "package you're installing running"?? You speak about its %post scripts? As I can understand all these tasks must be done when rpm returned with 0 status... Or not?

> If you use fuser when it fails, you should see
> the process that's running still
I try lsof grep by its mountpoint - nothing there. I'll try fuser (I wasn't use it before).

> We've made it in the future that the failure to unmount is fatal and stops the
> rest of the process there which should be a little bit more obvious,
Ok, it good idea.

> but we
> can't really do anything about fixing the %post of the packages you're
> installing :)  
I'm doubt what %post from rpm-packages may be running after rpm returned. So, I think we must search problem in other place.

I've reopen bug.

Comment 3 Jeremy Katz 2009-10-07 01:49:29 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Usually this is caused by a package you're installing running and not allowing
> > the filesystem to be unmounted.
> What mean "package you're installing running"?? You speak about its %post
> scripts? As I can understand all these tasks must be done when rpm returned
> with 0 status... Or not?

You can daemonize processes; it's generally a bad idea, but there are packages where it's done.

> > but we
> > can't really do anything about fixing the %post of the packages you're
> > installing :)  
> I'm doubt what %post from rpm-packages may be running after rpm returned. So, I
> think we must search problem in other place.
> 
> I've reopen bug.  

Trust me, you can.  I've tracked this down multiple times now and had it come back to that basically every time :(

Comment 4 Pavel Alexeev 2009-10-08 19:55:58 UTC
Actually I think it is Kernel bug or similar - https://bugzilla.redhat.com/show_bug.cgi?id=523436

And if you have made it in the future that the failure to unmount is fatal and stops the rest of the process as you say in 1 comment it will fully enough.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.