Bug 523208 - Fast user switch and VT
Fast user switch and VT
Status: CLOSED DUPLICATE of bug 512944
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-14 09:35 EDT by Luinnar
Modified: 2009-10-21 13:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 13:36:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luinnar 2009-09-14 09:35:48 EDT
Description of problem:
There are some problems with switching from VT2 to VT1 when two users are logged in via "fast user switch".

Version-Release number of selected component (if applicable):
LiveCD distribution testday-20090909-x86_64.iso.

How reproducible:
Steps to Reproduce:
There are some problems with switching from VT2 to VT1:
- login as a liveuser;
- create new user 'deaduser';
- switch to deaduser;
- switch back to liveuser;
- switch to VT2 and then back to VT1 - you should see the desktop of liveuser;
- now switch to deaduser;
- and do the same: switch to VT2 and then back to VT1 - you'll see a login screen for liveuser (with password prompt), whereas the desktop of deaduser is expected, it's a BUG.
- moreover, if you then press "Switch User" button in the login dialog - you'll see a white rectangle in the middle of the screen and you can't do anything there, it's a BUG. If you move the mouse over that rectangle it'll be in state "in progress". And the only way to return to the desktop is to switch to VT2 and then back to VT1, you'll get a login screen for liveuser.
  
Actual results:
Find "BUG" in the section above.

Expected results:
Switching from VT2 to VT1 should work fine for both logged in users.

Additional info:
Motherboard: Asus M3A-H/HDMI
Video: ATI Radeon HD3200 GPU (Integrated).
Comment 1 Adam Williamson 2009-10-21 13:36:09 EDT
we've been investigating this in the blocker bug review meeting this morning. it seems there are many reports of this type across multiple types of video hardware. closing all reports as dupes of 512944, which is the earliest report. 512944 will be marked as a release blocker.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 512944 ***

Note You need to log in before you can comment on or make changes to this bug.