Bug 523270 - /usr/sbin/redhat_lsb_trigger.x86_64 hangs
Summary: /usr/sbin/redhat_lsb_trigger.x86_64 hangs
Keywords:
Status: CLOSED DUPLICATE of bug 514760
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-lsb
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lawrence Lim
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F12Blocker, F12FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2009-09-14 17:11 UTC by Nicolas Mailhot
Modified: 2014-03-26 01:01 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-21 16:56:12 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2009-09-14 17:11:58 UTC
Description of problem:

during yum transaction glibc cleanup stalls and a ps shows it is stuck running redhat_lsb_trigger.

# ps auwwwwxf|grep lsb
 root     22114  6.4  5.4 1059227952 216428 pts/0 S+ 18:53   0:18  |                   \_ /usr/sbin/redhat_lsb_trigger.x86_64


# kill -15  22114

 Nettoyage      : glibc-2.10.90-21.x86_64                                79/81 
/var/tmp/rpm-tmp.OE3SJQ: line 3: 22114 Erreur de segmentation  (core dumped) /usr/sbin/redhat_lsb_trigger.x86_64
  Nettoyage      : 1:net-snmp-libs-5.4.2.1-16.fc12.x86_64

Version-Release number of selected component (if applicable):

redhat-lsb-3.2-5.fc12.x86_64

Comment 1 Kevin Fenzi 2009-09-22 18:31:02 UTC
I just ran into the same thing here, except in my case after the glibc.x86_64 trigger segfault, it hung on updating glibc.i686 and I had to hard reset the machine.

Comment 2 Nicolas Mailhot 2009-10-16 21:38:36 UTC
In case that's not clear, this bug makes redhat_lsb_trigger consume all system resources, till the system stops responding (if you're lucky the noise made by the HD as the system starts swapping like mad alerts you there is a problem and you can kill the redhat_lsb_trigger process before the situation goes critical)

Comment 3 Thomas Moschny 2009-10-18 09:15:49 UTC
Here /usr/sbin/redhat_lsb_trigger.x86_64 simply segfaulted twice during yesterday's "yum upgrade", but the upgrade otherwise finished. No high load or other problems seen besides that message.

Message log:

redhat_lsb_trig[15740]: segfault at 7fff2af16ec8 ip 000000000040e971 sp 00007fff2af16ed0 error 6 in redhat_lsb_trigger.x86_64[400000+9f000]

Comment 4 Tom "spot" Callaway 2009-10-21 16:56:12 UTC

*** This bug has been marked as a duplicate of bug 514760 ***


Note You need to log in before you can comment on or make changes to this bug.