Bug 523270 - /usr/sbin/redhat_lsb_trigger.x86_64 hangs
/usr/sbin/redhat_lsb_trigger.x86_64 hangs
Status: CLOSED DUPLICATE of bug 514760
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lawrence Lim
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-09-14 13:11 EDT by Nicolas Mailhot
Modified: 2014-03-25 21:01 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 12:56:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-09-14 13:11:58 EDT
Description of problem:

during yum transaction glibc cleanup stalls and a ps shows it is stuck running redhat_lsb_trigger.

# ps auwwwwxf|grep lsb
 root     22114  6.4  5.4 1059227952 216428 pts/0 S+ 18:53   0:18  |                   \_ /usr/sbin/redhat_lsb_trigger.x86_64


# kill -15  22114

 Nettoyage      : glibc-2.10.90-21.x86_64                                79/81 
/var/tmp/rpm-tmp.OE3SJQ: line 3: 22114 Erreur de segmentation  (core dumped) /usr/sbin/redhat_lsb_trigger.x86_64
  Nettoyage      : 1:net-snmp-libs-5.4.2.1-16.fc12.x86_64

Version-Release number of selected component (if applicable):

redhat-lsb-3.2-5.fc12.x86_64
Comment 1 Kevin Fenzi 2009-09-22 14:31:02 EDT
I just ran into the same thing here, except in my case after the glibc.x86_64 trigger segfault, it hung on updating glibc.i686 and I had to hard reset the machine.
Comment 2 Nicolas Mailhot 2009-10-16 17:38:36 EDT
In case that's not clear, this bug makes redhat_lsb_trigger consume all system resources, till the system stops responding (if you're lucky the noise made by the HD as the system starts swapping like mad alerts you there is a problem and you can kill the redhat_lsb_trigger process before the situation goes critical)
Comment 3 Thomas Moschny 2009-10-18 05:15:49 EDT
Here /usr/sbin/redhat_lsb_trigger.x86_64 simply segfaulted twice during yesterday's "yum upgrade", but the upgrade otherwise finished. No high load or other problems seen besides that message.

Message log:

redhat_lsb_trig[15740]: segfault at 7fff2af16ec8 ip 000000000040e971 sp 00007fff2af16ed0 error 6 in redhat_lsb_trigger.x86_64[400000+9f000]
Comment 4 Tom "spot" Callaway 2009-10-21 12:56:12 EDT

*** This bug has been marked as a duplicate of bug 514760 ***

Note You need to log in before you can comment on or make changes to this bug.