Bug 523282 - "R " prefix in filerequires
Summary: "R " prefix in filerequires
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 18:01 UTC by Mamoru TASAKA
Modified: 2009-10-27 06:35 UTC (History)
6 users (show)

Fixed In Version: 4.7.1-3.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-21 13:36:26 UTC


Attachments (Terms of Use)
sample spec file (597 bytes, text/plain)
2009-09-14 18:01 UTC, Mamoru TASAKA
no flags Details

Description Mamoru TASAKA 2009-09-14 18:01:04 UTC
Created attachment 360980 [details]
sample spec file

Description of problem:
With the attached sample spec file, rpmlint warns:

[tasaka1@localhost SPECS]$ rpmlint ../RPMS/noarch/shebang-test-0-1.fc12.noarch.rpm 
shebang-test.noarch: W: spurious-executable-perm /usr/share/doc/shebang-test-0/sample.sh
shebang-test.noarch: W: doc-file-dependency /usr/share/doc/shebang-test-0/sample.sh R

However there is no dependency against R.

Version-Release number of selected component (if applicable):
rpmlint-0.91-1.fc12.noarch

How reproducible:
100%

Steps to Reproduce:
1. rpmbuild -bb shebang-test.spec (where
   shebang-test.spec is the attached one)
2. try rpmlint on the rebuilt binary rpm
3.
  
Actual results:
See above

Expected results:
No R dependency shown

Comment 1 Ville Skyttä 2009-09-14 21:00:55 UTC
Huh?  This is due to some changes in rpm.  --filerequire shows it as well:

$ rpm -qp --filerequire shebang-test-0-1.fc11.noarch.rpm
/usr/share/doc/shebang-test-0
/usr/share/doc/shebang-test-0/sample.sh R /bin/sh

I see the "R" there with both F-10's rpm-4.6.1-1.fc10.i386 and F-11's rpm-4.7.1-1.fc11.x86_64.  With CentOS 5's rpm-4.4.2.3-9.el5 it's not there:

$ rpm -qp --filerequire shebang-test-0-1.fc11.noarch.rpm
/usr/share/doc/shebang-test-0
/usr/share/doc/shebang-test-0/sample.sh /bin/sh

In the python bindings, everything from hdr[rpm.RPMTAG_FILEREQUIRE] seems to come out as "R $something" strings.  This seems to be a query time thing with newer rpm versions, not something hardwired into the headers at build time (it is shown with F-11's rpm also for EL-5 packages).

I don't have anything between EL-5's and F-10's rpm to test with.  Panu, Jindrich, thoughts?  Maybe related to http://rpm.org/gitweb?p=rpm.git;a=commitdiff;h=3d8656f040d2c780c88d0cd63594898f0605a6fa ?

Comment 2 Panu Matilainen 2009-09-15 05:51:18 UTC
Yup, unintended (and until now, unnoticed :) change of behavior in that commit, fixed now: http://rpm.org/gitweb?p=rpm.git;a=commitdiff;h=d846e6b0f829791e6ffce4fd496c9378bff19c43

Comment 3 Ville Skyttä 2009-09-15 17:43:23 UTC
Thanks, Panu.  I'm not yet sure if I'll bother trying to work around this in rpmlint, but probably not.  Reassiging to rpm and adjusting summary to track fixed package release status.

Comment 4 Panu Matilainen 2009-09-21 13:36:26 UTC
Fixed in rpm-4.7.1-6.fc12

Comment 5 Fedora Update System 2009-10-08 10:05:53 UTC
rpm-4.7.1-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/rpm-4.7.1-3.fc11

Comment 6 Fedora Update System 2009-10-27 06:34:52 UTC
rpm-4.7.1-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.