Bug 523288 - If you have IPv6 settings in a connection that you then share with all users, you lose the IPv6 part
If you have IPv6 settings in a connection that you then share with all users,...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Desktop
: 550270 (view as bug list)
Depends On:
Blocks: IPv6Blocker
  Show dependency treegraph
 
Reported: 2009-09-14 14:50 EDT by Suzanne Hillman
Modified: 2010-12-05 01:24 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-05 01:24:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Adds support for reading/writting IPv6 bits from/to ifcfg files (112.89 KB, patch)
2009-12-08 10:09 EST, Jirka Klimes
no flags Details | Diff

  None (edit)
Description Suzanne Hillman 2009-09-14 14:50:58 EDT
Description of problem:
If you have IPv6 settings in a connection that you then share with all users, you lose the IPv6 part (it's set to 'Ignore' when you go edit the connection) after the connection has been translated into the /etc/sysconfig/network-scripts format. I have only tried this with 'automatic'.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.996.1.git20090826.fc12.x86_64

How reproducible:
Always, it seems.

Steps to Reproduce:
1. In NM's connection editor, create a wired connection.
2. Go to "IPv6", and change 'Ignore' to 'Autoamtic', and apply.
3. Go back in to edit the connection, and click "Available to all users".
4. Go back in again to take a look at the connection.
  
Actual results:
The IPv6 settings were saved after 2, but gone in 4.

Expected results:
Should keep the settings information!

Additional info:
Comment 1 Jimmy Rentz 2009-10-03 20:34:40 EDT
I see the same problem while setting a manual address (2001:XXXX:XXXX:XXXX:XXXX/64).
Comment 2 Tore Anderson 2009-10-23 21:38:53 EDT
I can confirm that this bug is present in the F12 beta.  Any attempt to change the IPv6 setting from something else than «ignore» will not stick as long as the connection is set as available for all users (which is the default).

Tore
Comment 3 Bug Zapper 2009-11-16 07:22:57 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Tore Anderson 2009-11-21 05:15:39 EST
Still present in F12.  This bug should probably be blocking bug #195271 too, but it seems I can't add this myself.

Tore
Comment 5 Jirka Klimes 2009-12-08 10:09:46 EST
Created attachment 376920 [details]
Adds support for reading/writting IPv6 bits from/to ifcfg files

IPv6 settings are lost for system connections (connections available to all users),
because they are handled via ifcfg-rh plugin, that lacks IPv6 read/write part.

This patch adds the functionality to the plugin:
All the stuff except routes goes to ifcfg-* file. Routes reside in route6-* file.
Comment 6 Felix Schwarz 2009-12-31 11:53:46 EST
Patch works for me using a self-compiled NetworkManager-0.7.997-2.git20091214.fc12.x86_64
Comment 7 Dan Williams 2010-01-04 17:18:35 EST
*** Bug 550270 has been marked as a duplicate of this bug. ***
Comment 8 Dan Williams 2010-01-05 20:07:47 EST
Committed to master:

686425adcef5c81a3e72e6aa143fd267e3cb2212 (master)
Comment 9 Dan Williams 2010-01-11 13:58:04 EST
https://admin.fedoraproject.org/updates/NetworkManager-0.7.998-1.git20100106.fc12

(and also build into F13)

Please test and let me know!
Comment 10 Tore Anderson 2010-01-12 07:39:41 EST
Tested it a bit, seems to work mostly fine but I ran into a few bugs I think.

First I tried to save "automatic" config method.  That worked fine.  Then I set a "manual" address of 1234::1/64.  That also worked fine.  So I set it back to "automatic (addresses only)", which also appeared to work - but!  The IPV6ADDR=1234::1/64 line (or something like that) was not purged from my ifcfg-eth0 file.  Shouldn't it have been?

After that I tried to set it to the "link local only" method, and it appeared to save that OK, but when I re-entered the config dialogue box it had in reality saved it as "manual" with the 1234::1/64 address (probably due to the ifcfg-eth0 line left over from earlier).

Tore
Comment 11 Dan Williams 2010-01-20 19:35:42 EST
I think I've fixed the IPV6ADDR not being cleared upstream:

http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=79db4928544bd20a1cb259847d3606d0ca03dbdd
Comment 13 Scott Schmit 2010-05-02 18:32:53 EDT
This is fixed by NetworkManager-0.8.0-10.git20100502.fc12.x86_64.
Comment 14 Bug Zapper 2010-11-04 06:02:20 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2010-12-05 01:24:49 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.