Bug 523320 - mdadm --assemble --update=super-minor corrupts extern metadata superblocks
mdadm --assemble --update=super-minor corrupts extern metadata superblocks
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-14 17:11 EDT by Hans de Goede
Modified: 2009-11-05 16:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-05 16:52:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2009-09-14 17:11:44 EDT
Running a command like:
mdadm --assemble /dev/md0 --uuid=.... --run --auto=md --update=super-minor \
  /dev/sda /dev/sdb /dev/sdc /dev/sdd

Results in the metadata on the disks getting corrupted and the command failing
because "superblock on sda has disappeared"

I guess this is one to forward upstream, still filing it in RH bz to have a
bugnr to reference in the anaconda workaround patches.
Comment 1 Doug Ledford 2009-11-05 14:21:58 EST
Upstream version 3.0.3 is supposed to resolve this issue.

Note You need to log in before you can comment on or make changes to this bug.