Bug 523336 - User can't add printer via system-config-printer from VNC viewer
Summary: User can't add printer via system-config-printer from VNC viewer
Keywords:
Status: CLOSED DUPLICATE of bug 489344
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-14 22:32 UTC by Roland Roberts
Modified: 2009-09-15 10:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-15 10:27:14 UTC


Attachments (Terms of Use)

Description Roland Roberts 2009-09-14 22:32:44 UTC
Description of problem:

I have a user "admin" which is unprivileged attempting to add a printer using the GNOME menu System > Administration > Printing.  The user session is via VNC; that is, the server is running a VNC session for user "admin" and I am connecting to that from another host on the LAN.  The user is asked to authenticate as root and does so.  After adding all information for the new printer, the final step produces a dialog box which says 

Unauthorized Request (addPrinter)
You are not authorized to carry out the requested action

Version-Release number of selected component (if applicable):

system-config-printer-1.1.8-6.fc11.i586
PolicyKit-0.9-6.fc11.i586

How reproducible:


Steps to Reproduce:
1. Log in as normal user
2. Select System > Administration > Printing
3. Add a new printer
  
Actual results:

Permission denied with message describe earlier.

Expected results:

Printer added successfully.

Additional info:

When performing the same actions from the X console, I get a *second* request to authenticate as root at the point I get the "Unauthorized Request" message above.

Comment 1 Tim Waugh 2009-09-15 10:27:14 UTC
The root of the problem is that VNC sessions are not handled as console sessions.

Use System->Preferences->Authorizations to allow non-console sessions to perform printing administration tasks.

*** This bug has been marked as a duplicate of bug 489344 ***


Note You need to log in before you can comment on or make changes to this bug.