Bug 523344 - Major System Corruption After yum update
Summary: Major System Corruption After yum update
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-15 00:35 UTC by David Le Sage
Modified: 2010-06-28 14:39 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 14:39:28 UTC


Attachments (Terms of Use)

Description David Le Sage 2009-09-15 00:35:04 UTC
Description of problem:
I ran yum update on Fedora 11 in my office yesterday.  Upon reboot, the machine would lock.  Some symptoms were that it appeared to freeze after initialising Cobbler but befroe "Local" came up on scren.  Switching to interactive mode, I would try to skip these but to no avail.  It seemed to be be locking on trying to reach gdm.

Switching to init level 3, I could boot but discovered /var/logs no longer existed.  This may be why gdm failed; it was trying to write to /var/log. Could also be the problem with cobbler, etc.  


Also, from init level 3, manually attempting to run startx failed.  Linker reported problems as well.


This morning, another employee tried the same thing from a freshly installed Fedora.  Again, the machine ran fine until he rebooted after the yum update.


Another symptom is that, on dual screen computers, one screen will show a lot of snow.  This is during the attempt to boot via Plymouth, before reaching gdm.

Version-Release number of selected component (if applicable):
Fedoar 11 - yum update on morning of 14/09/2009 (Australian time.)

How reproducible:


Steps to Reproduce:
1. Install Fedora
2. Run yum update.
3. Reboot
  
Actual results:
Cannot boot.  Major system corruption as discussed above.

Expected results:
Stable system with updates applied.

Additional info:
As I have now reinstalled Fedora, I have not preserved any data.  Also, var/log was destroyed, as noted, so not much information from there. As it has happened to two people in this office it may be widespread.

Comment 1 David Le Sage 2009-09-15 00:56:06 UTC
Just to clarify, it was only when I rebooted that the problems became apparent.  I hadn't rebooted for the previous six days but I had been running yum update regularly.  It appears, therefore, to have been one of the updates that occurred sometime between Thursday and Monday (in Australia) that caused this issue.

Comment 2 A. Mani 2009-09-22 02:43:19 UTC
If /var/log can vanish, then it seems to be a security breach.

Comment 3 David Le Sage 2009-09-22 22:38:12 UTC
Where, exactly, would this security breach have occurred, ie, in the RH Brisbane office, where two machines have been affected, (one of which was a fresh install with yum updates immediately applied) or to the packages on the yum repo server itself, which would obviously have much graver consequences for customers?

Comment 4 A. Mani 2009-09-23 00:30:48 UTC
Not the yum repo servers. I never had any problems and nobody else has reported such a problem.

Try checking with rkhunter and the other forensic stuff as is appropriate.

Comment 5 Chuck Ebbert 2009-09-25 04:31:16 UTC
Were you also using hibernation?

Comment 6 David Le Sage 2009-09-27 21:59:04 UTC
No, neither myself nor the other person who had the same issue were using hibernation functionality.

Comment 7 Pierre Blavy 2010-04-02 08:26:37 UTC
I'm experiencing the same bug in FEDORA 12.
After some tryes, it's related with the kernel update : 2.6.32.10-90.fc12
I've provided additionnal dmesg and hardware information.

See --> https://bugzilla.redhat.com/show_bug.cgi?id=523344

Comment 8 Pierre Blavy 2010-04-02 09:01:36 UTC
ERRATUM : see bug 578422

Comment 9 Bug Zapper 2010-04-28 10:22:28 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Bug Zapper 2010-06-28 14:39:28 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.