This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 52338 - nanny erroneously causes fail-over of healty active node in fos cluster
nanny erroneously causes fail-over of healty active node in fos cluster
Status: CLOSED CURRENTRELEASE
Product: Red Hat High Availability Server
Classification: Retired
Component: piranha (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: kbarrett
Phil Copeland
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-22 18:18 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 15:12:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-22 18:18:10 EDT
Description of Problem:





Version-Release number of selected component (if applicable):

Piranha v. 0.4.17-2





How Reproducible: Sometimes





Steps to Reproduce:

1. Install fos cluster in busy network

2. Wait, sometimes days

3. Observe fail-over



Actual Results: Fail-over service works, but for wrong reason





Expected Results: Spurios fail-overs due to connection error to alive service should not occur





Additional Information: It should be quite easy to add a variable to lvs.cf in the services sections, where the nanny is allowed top make a given number of connection attempts before deciding that the service in question on the active node is dead. This exactly like the heartbeat works.
Comment 1 Phil Copeland 2002-01-17 17:15:35 EST
There is a much more up to date version of piranha available. Please use these
and get back to me if you are experiancing the same problems

ftp://ftp.linux.org/uk/pub/linux/piranha

you need to install scsi_reserve, ipvsadm and piranha in that order
additionally you'll notice two branchs 6.2 and 7.x, be aware that
the ipvsadm packages are specifit to the kernel version
the 6.2 branch is for 2.2 kernels and the 7.X for 2.4

NOTE: the web interface has changed since 0.4
you will have to start the interface using
	service piranha-gui start

you will have to setup a passwd fir the piranha user
	piranha-passwd <a passwd>

and you will have to connect to the interface using
	http://localhost:3636/
	(username piranha passwd <a passwd> as above)

Phil
=--=
Comment 2 Brent Fox 2002-06-04 15:12:33 EDT
Can we close this bug due to lack of feedback?
Comment 3 Phil Copeland 2002-06-04 16:50:45 EDT
Yeap!
CLOSED!

Note You need to log in before you can comment on or make changes to this bug.