This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 523382 - libvirtd segfault due to netcf libxslt initialization error
libvirtd segfault due to netcf libxslt initialization error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netcf (Show other bugs)
rawhide
All Linux
high Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtBlocker
  Show dependency treegraph
 
Reported: 2009-09-15 05:46 EDT by Mark McLoughlin
Modified: 2013-04-30 19:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-15 05:54:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-09-15 05:46:11 EDT
#0  0x0000000000000021 in ?? ()
#1  0x00007ffff50c6aac in xmlHashScanFull () from /usr/lib64/libxml2.so.2
#2  0x00007ffff50c6afc in xmlHashScan () from /usr/lib64/libxml2.so.2
#3  0x00007ffff5872994 in xsltShutdownExts () from /usr/lib64/libxslt.so.1
#4  0x00007ffff5861d21 in xsltFreeStylesheet () from /usr/lib64/libxslt.so.1
#5  0x00007ffff5ccf961 in drv_close (ncf=0x7fffd4003c20)
    at drv_initscripts.c:514
#6  0x00007ffff5ccd1d1 in ncf_close (ncf=0x7fffd4003c20) at netcf.c:103
#7  0x000000000045f65f in interfaceCloseInterface (conn=0x7fffd40009e0)
    at interface_driver.c:164
#8  0x00007ffff727acab in virUnrefConnect (conn=0x7fffd40009e0)
    at datatypes.c:269
#9  0x0000000000413248 in qemudFreeClient (client=0x6dc6a0) at qemud.c:2144
#10 qemudRunLoop (client=0x6dc6a0) at qemud.c:2217
#11 0x00000000004163f9 in main (argc=<value optimized out>, 
    argv=<value optimized out>) at qemud.c:3001

Fixed upstream by:

http://git.fedorahosted.org/git/netcf.git?p=netcf.git;a=commit;h=4926ddd27a
Comment 1 Mark McLoughlin 2009-09-15 05:54:29 EDT
Backported the fix to rawhide:

* Tue Sep 15 2009 Mark McLoughlin <markmc@redhat.com> - 0.1.0-3
- Fix libvirtd segfault caused by libxslt init issue (#523382)

Note You need to log in before you can comment on or make changes to this bug.