Bug 523387 - mdadm --stop /dev/md# should remove md# from sysfs and /dev
mdadm --stop /dev/md# should remove md# from sysfs and /dev
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-15 06:04 EDT by Hans de Goede
Modified: 2010-02-19 15:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-19 15:47:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2009-09-15 06:04:32 EDT
Doing:
mdadm --stop /dev/md#

Results in md# being removed from /proc/mdstat (as it should), but for some
reason /sys/block/md# (and thus the /dev/md# created by udev) stick around.

Monitoring udev events reveals that /sys/block/md# actually disappears, but
at the very end seems to get recreated (by mdadm I assume) for some strange
reason.
Comment 1 Bug Zapper 2009-11-16 07:25:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Doug Ledford 2010-02-19 15:47:08 EST
This doesn't appear to be related to mdadm in any way.  An strace of mdadm shows that it has nothing to do with the recreate events that the kernel issues to udev.  I suspect that when they attempted to change the kernel to completely remove stopped devices, that either race conditions or user space breakages were encountered, so now the kernel stops the active array and recreates a new, blank array place holder.  As such I'm closing this as WONTFIX (partially because regardless of whether or not it's fixed, mdadm isn't the culprit, and partially because I suspect it really needs to be WONTFIX until upstream decides to fix it).

Note You need to log in before you can comment on or make changes to this bug.