Bug 523392 - Add support for Sun 6540 storage arrays.
Summary: Add support for Sun 6540 storage arrays.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath
Version: 5.4
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 515171
Blocks: 518493 530243
TreeView+ depends on / blocked
 
Reported: 2009-09-15 10:23 UTC by RHEL Product and Program Management
Modified: 2016-04-26 14:16 UTC (History)
26 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-16 13:41:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1515 normal SHIPPED_LIVE device-mapper-multipath bug fix update 2009-11-16 13:41:35 UTC

Description RHEL Product and Program Management 2009-09-15 10:23:36 UTC
This bug has been copied from bug #515171 and has been proposed
to be backported to 5.4 z-stream (EUS).

Comment 6 Ben Marzinski 2009-09-18 18:53:40 UTC
Ported.

Comment 14 michal novacek 2009-10-21 17:07:43 UTC
old version: 0.4.7-30.el5
new version: 0.4.7-30.el5_4.1

I added the following piece to /etc/multipath.conf and restarted multipath:
       device {
               vendor                  "STK"
               product                 "FLEXLINE 380"
               getuid_callout          "/sbin/scsi_id -g -u -s /block/%n"
               prio_callout            "/sbin/mpath_prio_rdac /dev/%n"
               features                "0"
               hardware_handler        "1 rdac"
               path_grouping_policy    group_by_prio
               failback                immediate
               rr_weight               uniform
               no_path_retry           queue
               rr_min_io               1000
               path_checker            rdac
        }

I verified that running 'multipathd -k"show config"' ignores the configuration
with old version and recognizes it correctly for new version.

Customer confirmed that the issue is fixed.

Comment 15 Jong Bae KO 2009-10-24 06:36:16 UTC
Updated from the customer.
==========
Latest test using RHEL 5.4 with no modified rpm's  
kernel-2.6.18.164.2.1.el5
device-mapper-multipath-0.4.7-30.el5_4.2
kpartx-0.4.7-30.el5_4.2

multipath -ll -v2 returns expected result.
dd if=/dev/zero of=/mountpoint dumps data at expected speed.

Non modified initrd causes so many errors that it slows up the boot by four and a half minutes, when compared to running modified initrd:
mkinitrd -f /boot/initrd-$(uname -r).img $(uname -r) --preload=scsi_dh_rdac  
==========

Comment 21 errata-xmlrpc 2009-11-16 13:41:38 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1515.html


Note You need to log in before you can comment on or make changes to this bug.