Bug 5234 - need backward compatibility time zone config
Summary: need backward compatibility time zone config
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: timeconfig (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
high
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
: 5395 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-20 03:04 UTC by Ben Liblit
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-25 02:40:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Liblit 1999-09-20 03:04:32 UTC
When a program is running using the backward compatibility
libraries from "compat-glibc-5.2-2.0.7.1", it will not have
proper time zone configuration.

This is most apparent when sending e-mail from Netscape
Communicator using the "netscape-communicator-4.61-9"
package.  The "Date:" header in outgoing mail incorrectly
gives UTC time zone "+000" rather than whatever the local
machine is actually configured to use.

(Note, however, that this is really not a Netscape bug.  It
is a time configuration bug that affects any date-sensitive
application using the backward compatibility libraries.
Netscape just happens to be the most prominent such
application.)

Perhaps we need a "compat-timeconfig" package to go along
with "compat-glibc" ?

Comment 1 Bill Nottingham 1999-09-25 02:40:59 UTC
Set TZ=:/etc/localtime.

This is fixed in the latest netscape packages (4.61-12.)

Comment 2 Bill Nottingham 1999-09-27 17:05:59 UTC
*** Bug 5395 has been marked as a duplicate of this bug. ***

Netscape does not set the right time zone for outgoing
emails unless the TZ environment variable is set, i.e.:

export TZ=:/etc/localtime

This could also be put in /etc/bashrc (and cshrc or
whatever), so that other apps will have access to TZ as
well.


Note You need to log in before you can comment on or make changes to this bug.