Bug 523416 - debuginfo-install hasn't learned about existence of Provides: tag
debuginfo-install hasn't learned about existence of Provides: tag
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 523295 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-15 08:05 EDT by Matěj Cepl
Modified: 2014-01-21 18:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 15:04:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2009-09-15 08:05:31 EDT
Description of problem:
I have installed package freetype-freeworld and its -debuginfo package freetype-freeworld-debuginfo. freetype-freeworld provides freetype, but freetype-freeworld-debuginfo obviously cannot provide freetype-debuginfo.

Debuginfo-install should be smart enough to recognize that freetype is just a virtual provide and look for the correct debuginfo.

Version-Release number of selected component (if applicable):
yum-utils-1.1.23-3.fc12.noarch

How reproducible:
100%

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
unahppy debuginfo-install (and crashing abrt, but that's another issue)

Expected results:
installed freetype-freeworld-debuginfo

Additional info:
Comment 1 seth vidal 2009-09-15 11:42:54 EDT
so why don't you ask for rpmbuild to append all provides to the associated debuginfo pkg? Instead of putting this on debuginfo-install to magically know about these things?
Comment 2 seth vidal 2009-09-17 10:07:48 EDT
*** Bug 523295 has been marked as a duplicate of this bug. ***
Comment 3 seth vidal 2009-10-12 15:04:10 EDT
this is an rfe at best and not one I'm likely to do.

closing wontfix

Note You need to log in before you can comment on or make changes to this bug.