Bug 523437 - string error in elfutils.pot
Summary: string error in elfutils.pot
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: elfutils
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Roland McGrath
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-15 14:00 UTC by Domingo Becker
Modified: 2009-09-16 11:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-15 20:22:17 UTC


Attachments (Terms of Use)

Description Domingo Becker 2009-09-15 14:00:44 UTC
Description of problem:
There's a string in elfutils.pot [1] in line 1586 which seems to be wrong. 
It is the following:
msgid " Length  Number  % of total  Coverage\n"

It comes from 
#: ../src/readelf.c:2610
#, c-format

This means that the string in ../src/readelf.c:2610 should be
" Length  Number  %% of total  Coverage\n"
in order to be treatable by gettext library used by Fedora translations tools.

If this is not corrected, there will be no possibility to submit translations through translate.fedoraproject.org for any language. The error will not pass 'msgfmt -c' and will prevent any submission.

[1] https://translate.fedoraproject.org/projects/elfutils/master/


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Roland McGrath 2009-09-15 20:22:17 UTC
That string is a literal, not a format string.  See the source:

      fputs_unlocked (gettext ("\
 Length  Number  % of total  Coverage\n"), stdout);

Please file a bug for xgettext wrongly annotating this with "c-format".


Note You need to log in before you can comment on or make changes to this bug.