Bug 523488 - pinentry-qt4 broken
pinentry-qt4 broken
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pinentry (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-15 13:29 EDT by Rex Dieter
Modified: 2009-10-30 12:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-30 11:00:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2009-09-15 13:29:32 EDT
Posted to upstream list,
http://lists.gnupg.org/pipermail/gnupg-devel/2009-September/025353.html

Not sure, could have sworn this worked at one point, but can't get it to work for the life of me.

Both -qt and -gtk-2 seems to work ok, but as soon as I try -qt4, gpg-agent fails, my debug-level advanced
output includes:

2009-09-13 14:24:55 gpg-agent[27662] starting a new PIN Entry
gpg-agent[27662]: can't connect server: ec=4.16383
2009-09-13 14:24:56 gpg-agent[27662] can't connect to the PIN entry module: 
End of file
2009-09-13 14:24:56 gpg-agent[27662] command get_passphrase failed: No 
pinentry
gpg-agent[27662.7] DBG: -> ERR
Comment 1 Rex Dieter 2009-09-15 13:29:59 EDT
$ rpm -q pinentry-qt
pinentry-qt-0.7.6-1.fc11.x86_64
Comment 2 Rex Dieter 2009-09-16 13:22:57 EDT
%changelog
* Wed Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-3
- drop alternatives, use app-wrapper instead (borrowed from opensuse)
- -qt4 experimental subpkg, -qt includes qt3 version again  (#523488)


further upstream exchanges/testing, seems the problem lies with gpg-agent/pinentry-qt4 interaction.  Running pinentry-qt4 by hand seems to work ok.
Comment 3 Ben Boeckel 2009-09-22 17:43:26 EDT
I get the Qt4 version by default here. Not sure what caused the change though (I was getting the Qt3 for a while then Qt4 just started getting used).
Comment 4 Ben Boeckel 2009-10-24 15:01:42 EDT
KNode is using Qt4 and KMail is using Qt3, not sure why (they share env since they're both in Kontact).
Comment 5 Rex Dieter 2009-10-24 15:55:33 EDT
It should be consistently using the value of
pinentry-program ...
in ~/.gnupg/gpg-agent.conf
Comment 6 Rex Dieter 2009-10-30 11:00:58 EDT
Creepy, installed f12, works fine now, and can no longer reproduce errors.
Comment 7 Ben Boeckel 2009-10-30 11:30:02 EDT
Odd. I installed F12 and things started to move back to the non-Qt4 one :( .
Comment 8 Rex Dieter 2009-10-30 12:00:58 EDT
easy, 

rpm -e pinentry-qt 

(and make sure you're preferred one, like pinentry-qt4 *is* installed).

Note You need to log in before you can comment on or make changes to this bug.