Bug 523495 - [MRG] Group quotas do not work correctly when partitionable slots is turned on.
Summary: [MRG] Group quotas do not work correctly when partitionable slots is turned on.
Keywords:
Status: CLOSED DUPLICATE of bug 519183
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor
Version: 1.1
Hardware: All
OS: Linux
urgent
high
Target Milestone: 1.2
: ---
Assignee: grid-maint-list
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-15 18:02 UTC by Jon Thomas
Modified: 2009-10-05 18:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-05 18:32:40 UTC


Attachments (Terms of Use)

Description Jon Thomas 2009-09-15 18:02:20 UTC
When partitionable slots are turned on, job scheduling between user groups do not seem to observe their configured quotas.

For our tests we configured two groups:

GROUP_NAMES = group_a, group_b (or group_dragon, group_shrek)
GROUP_QUOTA_DYNAMIC_group_a = 0.80
GROUP_QUOTA_DYNAMIC_group_b = 0.20
GROUP_AUTOREGROUP_group_a = TRUE
GROUP_AUTOREGROUP_group_b = TRUE

When jobs for each group were submitted with partitioned slots turned on, we observed a [very rough] 1:1 ratio.

When jobs for each group were submitted with partitioned slots turned off, we observed the expected 4:1 ratio.

Comment 1 Jon Thomas 2009-09-16 15:39:34 UTC
A potential config solution for this may be:

GROUP_DYNAMIC_MACH_CONSTRAINT = DynamicSlot =!= TRUE && Cpus > 0

Also may need "&& Memory > x" where x is some threshold.

Comment 2 Jon Thomas 2009-10-05 17:30:54 UTC
This can probably be closed as dup of https://bugzilla.redhat.com/show_bug.cgi?id=519183

Comment 3 Matthew Farrellee 2009-10-05 18:32:40 UTC

*** This bug has been marked as a duplicate of bug 519183 ***


Note You need to log in before you can comment on or make changes to this bug.