Bug 523504 - FATAL ERROR aborting: failed to read fragment table
Summary: FATAL ERROR aborting: failed to read fragment table
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: squashfs-tools
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kyle McMartin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-15 18:20 UTC by Andre Robatino
Modified: 2015-09-01 03:53 UTC (History)
3 users (show)

Fixed In Version: squashfs-tools-4.0-4.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-06 03:36:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 655952 None None None Never

Internal Links: 655952

Description Andre Robatino 2009-09-15 18:20:34 UTC
Description of problem:
When running the F11 version of unsquashfs on the file LiveOS/squashfs.img in the F10-i686-Live.iso Live CD image, the following error occurs (after loop mounting with fuseiso):

[andre@compaq-pc tmp]$ unsquashfs tmp1/LiveOS/squashfs.img 
Parallel unsquashfs: Using 1 processor
FATAL ERROR aborting: failed to read fragment table

This happens on both x86_64 and i686 F11 boxes, when run using the F10 image.  However, it works properly on the same file in the Fedora-11-i686-Live.iso Live CD image.  Both images were verified against their respective checksum files after downloading.

Version-Release number of selected component (if applicable):
squashfs-tools-4.0-1

How reproducible:
always

Steps to Reproduce:
1. Download and verify F10-i686-Live.iso.
2. Loop mount the ISO.
3. Run unsquashfs on LiveOS/squashfs.img.

Comment 1 Andre Robatino 2009-09-15 20:09:32 UTC
Same bug exists on x86_64 Rawhide (also with F10-i686-Live.iso).  Bumping Version to rawhide.

Comment 2 Bug Zapper 2009-11-16 12:26:46 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Andre Robatino 2010-01-03 05:43:53 UTC
Still exists in Rawhide with squashfs-tools-4.0-2.x86_64 (testing with F10-i686-Live.iso as before).  Bumping Version to rawhide.

Comment 4 Bug Zapper 2010-03-15 12:50:06 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Phillip Lougher 2010-05-05 02:29:44 UTC
This is a bug in the Squashfs 4.0 release of unsquashfs. The bug fix (which has been in Squashfs CVS for over a year) is here http://squashfs.cvs.sourceforge.net/viewvc/squashfs/squashfs/squashfs-tools/unsquash-3.c?r1=1.10&r2=1.11

This bug only affects reading 3.x file systems.  I imagine the F10 image is a 3.x file system whereas the F11 image is 4.0, so it isn't affected by the bug.

Comment 6 Fedora Update System 2010-05-06 03:25:10 UTC
squashfs-tools-4.0-4.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/squashfs-tools-4.0-4.fc13

Comment 7 Fedora Update System 2010-05-06 03:26:00 UTC
squashfs-tools-4.0-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/squashfs-tools-4.0-3.fc12

Comment 8 Kyle McMartin 2010-05-06 03:36:18 UTC
Will be in the next release of squashfs-tools for F-12/13/rawhide. Thanks pkl!

cheers, Kyle

Comment 9 Andre Robatino 2010-05-06 12:26:40 UTC
Works for me on F12/13.

Comment 10 Fedora Update System 2010-05-10 17:02:45 UTC
squashfs-tools-4.0-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-06-24 16:21:43 UTC
squashfs-tools-4.0-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.