Bug 523515 - xine no longer plays mp3s
Summary: xine no longer plays mp3s
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xine-lib
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-15 19:06 UTC by Christian
Modified: 2009-09-16 16:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 16:23:40 UTC


Attachments (Terms of Use)
Output of xine --bug-report on an MP3 file (26.55 KB, text/plain)
2009-09-16 02:14 UTC, Christian
no flags Details

Description Christian 2009-09-15 19:06:55 UTC
Description of problem:

Audio players using xine as the backend no longer play mp3 files. I can't say when this started, but this worked fine until recently. 

Version-Release number of selected component (if applicable):

rpm -qa | grep xine
xine-lib-1.1.16.3-2.fc11.i586
phonon-backend-xine-4.3.1-6.fc11.i586
xine-lib-extras-1.1.16.3-2.fc11.i586
xine-lib-extras-freeworld-1.1.16.3-1.fc11.i586
xine-ui-0.99.5-16.fc11.i586
xine-lib-pulseaudio-1.1.16.3-2.fc11.i586
xine-plugin-1.0.2-2.fc11.i586

How reproducible:

100%.

Steps to Reproduce:
1. Run amarok or juk, with xine as audio backend configured in KDE
2. Attempt to play an MP3 file
  
Actual results:

The message "xine is asking to seek behind the end of the data stream" is printed to the console, and the file is skipped/not played.

Expected results:

MP3 should be decoded and playing.

Additional info:

Audio generally works, other file formats (such as OGG) are playing fine as well. I was under the impression that xine-lib-extras-freeworld is all that's needed to play MP3?

Comment 1 Rex Dieter 2009-09-15 19:26:44 UTC
Unfortunately, I can't reproduce.

works fine here using amarok, you're right about xine-lib-extras-freeworld too.

Comment 2 Christian 2009-09-15 23:13:07 UTC
Mhmm ... okay, any suggestions for where to start debugging?

Comment 3 Kevin Kofler 2009-09-15 23:20:03 UTC
Try running:
package-cleanup --problems
and:
rpm -Va

I suspect xine-lib-extras-freeworld or one of its dependencies (libmad?) is corrupt or missing entirely.

Comment 4 Christian 2009-09-16 02:13:59 UTC
Thanks Kevin -- sorry, but that didn't help. package-cleanup reports no problems, and the changes reported by rpm -Va are unrelated. I did reinstall the xine-lib-extras-freeworld and libmad RPMs.

I ran xine --bug-report on a test MP3 file for which the file command reports:

test.mp3: Audio file with ID3 version 2.3.0, contains: MPEG ADTS, layer III, v1, 128 kbps, 44.1 kHz, Stereo

The report file (attached) clearly indicates that a demux plugin is missing, but I don't know how to fix that. Help is greatly appreciated.

Comment 5 Christian 2009-09-16 02:14:36 UTC
Created attachment 361172 [details]
Output of xine --bug-report on an MP3 file

Comment 6 Rex Dieter 2009-09-16 13:40:19 UTC
difference for me, when I run xine --bug-report... I see a line:

load_plugins: probing demux 'mp3'

which I believe comes from xineplug_decode_mad.so

So, for you, check:

$ rpm -qV xine-lib-extras-freeworld libmad

$ rpm -q -f /usr/lib/xine/plugins/1.26/xineplug_decode_mad.so

$ ldd -r    /usr/lib/xine/plugins/1.26/xineplug_decode_mad.so

If all this checks out, I'm stumped.

Comment 7 Christian 2009-09-16 15:19:31 UTC
Rats, I'm afraid they all check out. :(

(In reply to comment #6)
> $ rpm -qV xine-lib-extras-freeworld libmad

This one finds no differences.

> $ rpm -q -f /usr/lib/xine/plugins/1.26/xineplug_decode_mad.so
xine-lib-extras-freeworld-1.1.16.3-1.fc11.i586

> $ ldd -r /usr/lib/xine/plugins/1.26/xineplug_decode_mad.so
        linux-gate.so.1 =>  (0x00c87000)
        libxine.so.1 => /usr/lib/libxine.so.1 (0x00e01000)
        libdl.so.2 => /lib/libdl.so.2 (0x00d03000)
        libz.so.1 => /lib/libz.so.1 (0x00731000)
        librt.so.1 => /lib/librt.so.1 (0x00204000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x00870000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x00d6f000)
        libmad.so.0 => /usr/lib/libmad.so.0 (0x00176000)
        libm.so.6 => /lib/libm.so.6 (0x005cf000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x00cdb000)
        libc.so.6 => /lib/libc.so.6 (0x0020d000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00110000)
        /lib/ld-linux.so.2 (0x00143000)

I'm poking through some straces to perhaps get an idea.

Comment 8 Christian 2009-09-16 16:23:40 UTC
I came across http://ubuntuforums.org/showthread.php?t=337209 , deleted ~/.xine, and things work again. Thanks all for the help.


Note You need to log in before you can comment on or make changes to this bug.