Bug 523525 - unable to start klavaro
Summary: unable to start klavaro
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: klavaro
Version: 11
Hardware: i586
OS: Linux
low
medium
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 539829 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-15 19:48 UTC by Craig Goodyear
Modified: 2010-02-09 10:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-09 10:04:41 UTC


Attachments (Terms of Use)
bug buddy crash report (262.31 KB, text/plain)
2009-09-15 19:58 UTC, Craig Goodyear
no flags Details
crash output from terminal (4.01 KB, text/plain)
2009-09-15 23:25 UTC, Craig Goodyear
no flags Details

Description Craig Goodyear 2009-09-15 19:48:00 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Craig Goodyear 2009-09-15 19:57:01 UTC
sorry for the premature post.


Description of problem:
klavaro crashes immediately when trying to start

Version-Release number of selected component (if applicable):
klavaro-1.2.4-1.fc11.i586

How reproducible:
every time

Steps to Reproduce:
1. try to start klararo from panel menu or from terminal

Actual results:
Bug Buddy pops up saying:
The application klavaro has crashed.

Expected results:
program to start

Additional info:
bug report is added below

Comment 2 Craig Goodyear 2009-09-15 19:58:48 UTC
Created attachment 361127 [details]
bug buddy crash report

Comment 3 Mathieu Bridon 2009-09-15 22:35:29 UTC
[Note: I received a notification about this issue as I'm co-maintaining Klavaro in Fedora]

I can't reproduce your issue, Klavaro runs absolutely fine here (although I'm on x86_64, but I don't know if that could be an arch-dependant issue).

Do you have any more messages in the terminal when you run Klavaro from there ?

Comment 4 Craig Goodyear 2009-09-15 23:23:59 UTC
See the below attachment for the output from running from a terminal.

I have just install klavaro on another system that is running Fedora 11 
x86_64 and the program started without a problem.

Comment 5 Craig Goodyear 2009-09-15 23:25:44 UTC
Created attachment 361163 [details]
crash output from terminal

Comment 6 Fabian Affolter 2009-09-16 21:57:18 UTC
On my Fedora 11 i386 machine klavaro is working as expected. The same on my x86_64 Fedora 11 system.

Comment 7 Craig Goodyear 2009-09-17 21:21:54 UTC
(In reply to comment #6)
> On my Fedora 11 i386 machine klavaro is working as expected. The same on my
> x86_64 Fedora 11 system.  

I have just installed klavaro on my other two Fedora 11 i686 systems.  I had the same results as the original bug report, an immediate crash from both the panel menu and a terminal on each install.

I then installed klavaro in a VirtualBox vm running Fedora 10 i686.  The initial start from the panel menu resulted in a crash.  I then tried to start klavaro from a terminal, and it started without an error.  I was then able to start the klavaro from the panel menu without an error.

Comment 8 Mathieu Bridon 2009-09-18 08:50:13 UTC
Random issue ?

Maybe we forgot a runtime dependency. If it's not installed, Klavaro crashes, if it is then Klavaro runs fine.

For the record, I reproduced this issue on a F11 i386 VM without GNOME installed, only LXDE and the Klavaro dependenies.

I'll try to have a look at it this week-end, if you don't beat me to it Fabian :)

Comment 9 Fabian Affolter 2009-09-22 20:14:46 UTC
(In reply to comment #8)
> I'll try to have a look at it this week-end, if you don't beat me to it Fabian
> :)  

Just go ahead.

Perhaps we should go upstream with this issue...

Comment 10 Mathieu Bridon 2009-09-28 18:43:03 UTC
Sorry it took so long. I've been looking at it this week-end, but didn't find anything unfortunately.

Fabian, do you have a Sourceforge account to report the issue ? I don't, but I'll open one in case it is needed.

Comment 11 Fabian Affolter 2009-10-02 09:20:59 UTC
The latest version of klavaro is 1.3.2. I will make an update.  If the issue still occurs after some retesting then I will involve upstream.

Comment 12 Mathieu Bridon 2009-10-02 12:48:11 UTC
For the record, I managed to reproduce the issue:
- install Fedora 11 WITHOUT GNOME AND X
- install only the necessary bits to be able to run an X session (Xorg, TWM, xterm,...)
- install klavaro
- run klavaro and look at the crash

I did that with F11-i386, but I suspect the same would happen with x86_64.

Comment 13 Fabian Affolter 2009-10-07 14:32:50 UTC
The update for 1.3.3

https://admin.fedoraproject.org/updates/klavaro-1.3.3-1.fc11

So, I think that we should add a dependency to avoid the crash.

Comment 14 william.hoffmann 2009-10-20 06:47:21 UTC
The latest version (klavaro-1.3.3-1.fc11.i586) keeps crashing. For the records I'm not using gnome but xmonad. I've the same message that #5.

Comment 15 william.hoffmann 2009-10-20 06:55:22 UTC
A simple LANG=C klavaro seems to solve the problem.

Comment 16 Mathieu Bridon 2009-10-20 17:25:13 UTC
For the record, it's also hitting Ubuntu:
https://bugs.launchpad.net/ubuntu/+source/klavaro/+bug/439753

Comment 17 Mathieu Bridon 2009-11-21 09:20:49 UTC
*** Bug 539829 has been marked as a duplicate of this bug. ***

Comment 18 Fabian Affolter 2010-01-05 09:32:44 UTC
klavaro 1.4.0 was pushed to stable a while ago

https://admin.fedoraproject.org/updates/F12/FEDORA-2009-13471

Comment 19 Fabian Affolter 2010-02-09 10:04:41 UTC
The current version in Fedora 1.4.1.  If this issue still occurs please reopen the bug report.


Note You need to log in before you can comment on or make changes to this bug.