Bug 523529 - ip= seems to be ignored
Summary: ip= seems to be ignored
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-15 20:24 UTC by Brad Smith
Modified: 2009-12-21 01:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-21 01:58:00 UTC


Attachments (Terms of Use)
contents of /tmp during install (8.15 MB, application/x-bzip-compressed-tar)
2009-09-18 17:00 UTC, Brad Smith
no flags Details

Description Brad Smith 2009-09-15 20:24:24 UTC
Description of problem:
I have a system setup to install according to options described in my PXE configuration. These include ks=, ip= and netmask= settings. If I only use ks=http://192.168.0.254/workstation.cfg, anaconda gets a dhcp lease and kicks just fine. 

If I add ip=192.168.0.254, it says that it can't find the ks server, even though it's on the same subnet (192.168.0.254). 

When I add netmask=255.255.255.0, again the kick works fine, but it gets a dhcp lease, ignoring the ip= setting.

Version-Release number of selected component (if applicable):
anaconda-11.1.2.195-1, or whatever is the default with RHEL5.4

How reproducible:
Always, at least for me.

Comment 1 Brad Smith 2009-09-15 20:48:08 UTC
Also, I should note that while in anaconda I have used 'cat /proc/cmdline' to verify the existence of the ip= and netmask= options, and have used ifconfig and the logs to verify that I am instead getting a different IP via DHCP.

Comment 2 David Cantrell 2009-09-15 22:49:14 UTC
Brad,

Are you passing a ksdevice=ethX parameter as well?  If not, try that.

Comment 3 Brad Smith 2009-09-16 14:32:05 UTC
Yes. The complete list of options being passed are:

ksdevice=eth0 load_ramdisk=1 initrd=initrd.img network ks=http://192.168.0.254/workstation.cfg noipv6 ip=192.168.0.5 netmask=255.255.255.0

Note that the .254 ip= value I mentioned in my initial report was a typo

Comment 4 David Cantrell 2009-09-17 00:35:12 UTC
Can you pass loglevel=debug and start up the installer and get to the graphical part, then go to tty2 and collect the contents of /tmp and attach it to this bug.

Comment 5 Brad Smith 2009-09-18 17:00:47 UTC
Created attachment 361690 [details]
contents of /tmp during install

Tried setting everything up from scratch again. Same behavior as before: ip= seems to be being ignored. I set loglevel=debug and am attaching a tarball of /tmp. I excluded the header files, as they took up a lot of space and I'm assuming they're not relevant. I also created a /tmp/anaconda_info/ with the contents of /proc/cmdline and the output of ifconfig.

Comment 6 David Cantrell 2009-09-30 02:31:48 UTC
Looking at /tmp/anaconda.log, loader does set up eth0 with the static IP but when it tries to fetch the kickstart file, that fails.  So it goes back and tries dhcp on eth0.  DHCP succeeds and the system uses 192.168.0.20.

I don't know the details of your LAN configuration.  Can you try passing the gateway= parameter as well as the ip= and netmask= parameter?  Based on the DHCP lease you received, your gateway is also 192.168.0.254.

Comment 7 David Cantrell 2009-12-21 01:43:46 UTC
No additional info provided, cannot reproduce on my VMs.

Comment 8 RHEL Product and Program Management 2009-12-21 01:58:00 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.