Bug 52357 - GUI login fails in both kde and gnome
GUI login fails in both kde and gnome
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-22 20:47 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-22 20:47:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-22 20:47:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
GUI login fails. Under gnome it just returns to login screen after entering
correct username and password.  If incorrect data entered, login screen
returns that login is not authorized (as it should). Under kde, the
following error is returned after attempting to login: :startup program
/etc/X11/xdm/GiveConsole exited with non-zero status. I am able to login
from the console and then run X (as root) by startx. If I login as another
user from the console and use startx it is erratic whether or not I can get
to a graphics screen. Sometimes yes and at other times get it fails with "
kdeinit: Fatal IO error". 
I am running RedHat 7.1 with 2.4.2-2 kernel and XFree 4.0.3-5. I have a
Matrox Millenium G-400 AGP with 32MB memory and XFree is using the
XFree86-SVGA and mga driver. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot an init level 5	
2.GUI login presents itself
3.login fails as noted above
	

Actual Results:  See above, depends on whether I boot to Gnome default or
KDE.

Expected Results:  Should have been able to login and go to appropriate
desktop

Additional info:

I had trouble initially installing because the mouse was not recognized due
to IRQ conflict with sound card, so that X would not run adn continually
failed. Reported to support, but they were not helpful. Finally found cause
for X failure and corrected IRQ issue, but then had login problem. Reported
login problem and they said I should come to bugzilla.
Comment 1 Mike A. Harris 2001-09-01 08:45:52 EDT
This is most likely misconfiguration.  xdm/gdm/kdm login works
perfectly fine in all of our QA testing.  Please rerun Xconfigurator
and reconfigure X.  If you are using a non-bash login shell you
may also experience different problems.

Unreproduceable.
Comment 2 Need Real Name 2001-09-02 11:08:10 EDT
I ran Xconfigurator multiple times without relief. Finally I installed Redhat
7.1 as a new install and allowed it to reformat my disk. I originally had run
the redhat install as an upgrade. Once I ran it as a new workstation, the
problem went away. I can only conclude that the upgrade installation does not
remove or change things to prevent conflicts from the prior version. I can now
login without a problem. I cannot tell you more, but you may want to check the
upgrade installation.

Note You need to log in before you can comment on or make changes to this bug.