Bug 52358 - pam_krb5 needs -minuid option
pam_krb5 needs -minuid option
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pam_krb5 (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-22 22:17 EDT by Matthew Miller
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 20:30:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2001-08-22 22:17:14 EDT
In short: need a way to set a "minimum UID" below which accounts are not
ever kerberos authenticated.

Longer: in large-scale but only loosely centralized environments (i.e.
universities), it's important to have a convention where user accounts with
UIDs below a certain number are never checked against kerberos. This makes
it easy to set up local accounts with arbitrary names without causing
chaos. For example, my official centralized kerberos account is "mattdm",
but perhaps on some machine I want it to be "matthew" -- even though there
is already a different person with the "official" matthew account. With the
system mentioned above, it's no problem, as long as I set a local password
and have a UID less than the limit.

Chris Wing's pam_kafs
<http://www-personal.engin.umich.edu/~wingc/pam_kafs.html> implements
exactly this, but just for kerberos 4. Your kerberos 5 module is very nice,
and it'd be great to have this option.
Comment 1 Matthew Miller 2001-08-22 22:32:30 EDT
Additional info -- pam_localuser is no help, since not everyone with a central
account should have access to all machines. In some cases, accounts might be in
NIS or LDAP, but usually, a local account is created and just the password is
networked. I've looked for a pam_uidrange or somesuch, but with no luck.
Comment 2 Nalin Dahyabhai 2001-08-24 19:38:10 EDT
Should be present in 1.44, coming soon to a Raw Hide near you.  Please reopen
this bug if you find that "minimum_uid=somenumber", either on the command-line
in the PAM configuration file, or in /etc/krb5.conf, doesn't do the right thing.
Comment 3 Matthew Miller 2001-08-24 20:16:24 EDT
Awesome; I'm impressed. Thanks much for the quick response. I'll check it out
either tomorrow or Sunday.
Comment 4 Matthew Miller 2001-08-24 20:30:44 EDT
Actually, I played with it a bit just now, and it seems to work exactly as
advertised. Thanks again!
Comment 5 Nalin Dahyabhai 2001-08-30 17:44:24 EDT
Cool beans.
Comment 6 Matthew Miller 2003-02-20 14:57:55 EST
Y'know, this option doesn't seem to have made it into the documentation ever...

Note You need to log in before you can comment on or make changes to this bug.