Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 523644 - grub.gonf not updated to new kernel-2.6.31-12.fc12.x86_64
Summary: grub.gonf not updated to new kernel-2.6.31-12.fc12.x86_64
Keywords:
Status: CLOSED DUPLICATE of bug 527528
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: rawhide
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 10:01 UTC by Flóki Pálsson
Modified: 2009-10-28 11:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-28 11:11:14 UTC
Type: ---


Attachments (Terms of Use)
files in /boot and grub.conf (1.77 KB, text/plain)
2009-09-16 10:01 UTC, Flóki Pálsson
no flags Details
yumex falure to update kernel (5.06 KB, text/plain)
2009-10-27 18:40 UTC, Flóki Pálsson
no flags Details

Description Flóki Pálsson 2009-09-16 10:01:43 UTC
Created attachment 361225 [details]
files in /boot and grub.conf

Description of problem:
Udatting with yumex then after instalition off new kernel-2.6.31-12.fc12.x86_64 then grub.conf is not updated.
initramfs is missing.

Version-Release number of selected component (if applicable):
grub-0.97-59.fc12.x86_64

kernel-2.6.31-2.fc12.x86_64
kernel-2.6.31-12.fc12.x86_64
How reproducible:


Steps to Reproduce:
1.
update with yumex
2.
3.
  
Actual results:
grub.conf not updtes and initramfs

Expected results:
grub.conf udted and initramfs in /boot

Additional info:
this is fully udated f12 insalleed from new F12-Snap2-x86_64-Live.

Comment 1 Flóki Pálsson 2009-09-16 20:48:54 UTC
I solved this by removing kernel-2.6.31-12.fc12.x86_64 with yumex and yum update kernel.  Then initramfs was installed and grub.cong updated.
This is related to permission problem, I noticed that in yumex output log.

Comment 2 Flóki Pálsson 2009-09-17 00:53:21 UTC
Permission problem
0:52:19 : Installed kernel-2.6.31-14.fc12.x86_64
00:52:20 : YUM: /sbin/new-kernel-pkg: line 300: /sbin/depmod: Permission denied

00:53:20 : YUM: /usr/bin/ldd: line 118: /sbin/udevd: Permission denied

00:53:21 : YUM: E: Failed to install /lib/libnss_files*

00:53:21 : YUM: mkinitrd failed

00:53:21 : YUM: Non-fatal POSTIN scriptlet failure in rpm package kernel-2.6.31-14.fc12.x86_64

00:53:21 : YUM: RPM Scriptlet: warning: %post(kernel-2.6.31-14.fc12.x86_64) scriptlet failed, exit status 1
00:53:22 : Updated rpm-4.7.1-5.fc12.x86_64

Comment 3 Flóki Pálsson 2009-10-27 18:40:22 UTC
Created attachment 366317 [details]
yumex falure to update kernel 

This is still in 
yumex-2.9.3-1.fc12.noarch

Changed component from grub to yumex

Comment 4 Adam Williamson 2009-10-28 01:23:56 UTC
This has been confirmed by several forum users, they all had trouble upgrading the kernel with yumex, yum and PackageKit don't have any trouble.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Tim Lauridsen 2009-10-28 11:11:14 UTC
it is a SELinux issue, check other bugreport for details

*** This bug has been marked as a duplicate of bug 527528 ***


Note You need to log in before you can comment on or make changes to this bug.