Bug 52365 - xinetd[2702]: {general_handler} (2702) Unexpected signal: 11 (Segmentation fault)
Summary: xinetd[2702]: {general_handler} (2702) Unexpected signal: 11 (Segmentation fa...
Status: CLOSED DUPLICATE of bug 48367
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-23 04:00 UTC by Alejandro Gonzalez Hernandez - Imoq
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-23 04:02:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alejandro Gonzalez Hernandez - Imoq 2001-08-23 04:00:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Lately, I have been receiving this kind of error messages from xinetd:

Aug 22 22:42:41 principal xinetd[2682]: {bad_signal} Received 10 signals 
in 1 seconds. Exiting...
Aug 22 22:48:32 principal xinetd[2702]: {general_handler} (2702) 
Unexpected signal: 11 (Segmentation fault)
Aug 22 22:48:32 principal last message repeated 9 times
Aug 22 22:48:32 principal xinetd[2702]: {bad_signal} Received 10 signals 
in 1 seconds. Exiting...
Aug 22 22:50:37 principal xinetd[2709]: {general_handler} (2709) 
Unexpected signal: 11 (Segmentation fault)
Aug 22 22:50:37 principal last message repeated 9 times
Aug 22 22:50:37 principal xinetd[2709]: {bad_signal} Received 10 signals 
in 1 seconds. Exiting...


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Some lusers complain they can't check their email via pop3.
2. tail /var/log/messages
3. see the error messages.
	

Actual Results:  Ugly error messages.

Expected Results:  POP3 retreival to work.

Additional info:

It has happen three times now, one of my users complain they can't access 
their pop3 email, and I look at the /var/log/messages and find this:

Aug 22 22:42:41 principal xinetd[2682]: {bad_signal} Received 10 signals 
in 1 seconds. Exiting...
Aug 22 22:48:32 principal xinetd[2702]: {general_handler} (2702) 
Unexpected signal: 11 (Segmentation fault)
Aug 22 22:48:32 principal last message repeated 9 times
Aug 22 22:48:32 principal xinetd[2702]: {bad_signal} Received 10 signals 
in 1 seconds. Exiting...
Aug 22 22:50:37 principal xinetd[2709]: {general_handler} (2709) 
Unexpected signal: 11 (Segmentation fault)
Aug 22 22:50:37 principal last message repeated 9 times
Aug 22 22:50:37 principal xinetd[2709]: {bad_signal} Received 10 signals 
in 1 seconds. Exiting...

Now, I check my email via imaps and I haven't had any problem with that.

All errata has been applied to that system, for what it's worth:

[root@myhost /root]# rpm -qa | grep xinetd
xinetd-2.3.0-1.71

Comment 1 Alejandro Gonzalez Hernandez - Imoq 2001-08-23 04:02:48 UTC
Duh! I forgot to mention:

service xinetd stop
service xinetd start

seems to fix the problem (until it's present again, at least).


Comment 2 Trond Eivind Glomsrxd 2001-08-23 04:15:41 UTC

*** This bug has been marked as a duplicate of 48367 ***

Comment 3 Davide Giansoldati 2003-01-27 12:10:19 UTC
Hello i have the same problem

Jan 16 09:04:34 www xinetd[896]: {general_handler} (896) Unexpected signal: 11 (
Segmentation fault)

my os is redhat 7.2 i386 on a dual P3 550

How can I solve it?

 rpm -q xinetd gives xinetd-2.3.7-4.7x

Thx in advance

Davide


Note You need to log in before you can comment on or make changes to this bug.