Bug 523697 - traceback (OverflowError) when running dwscan
Summary: traceback (OverflowError) when running dwscan
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: dwscan
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 13:29 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2010-02-09 10:05 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-09 10:05:22 UTC


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2009-09-16 13:29:36 UTC
Description of problem:
dwscan aborts with a traceback when run, which makes it unusable.

Version-Release number of selected component (if applicable):
dwscan-0.2-3.fc11

How reproducible:
Always

Steps to Reproduce:
1. run dwscan
  
Actual results:
Traceback (most recent call last):
  File "/usr/sbin/dwscan", line 214, in <module>
    scanresults = ifobj.scan()
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 410, in scan
    return iwscan.scan()
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 970, in scan
    result = self.getScan()
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 1022, in getScan
    self.aplist = self._parse(buff.tostring())
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 1056, in _parse
    data[pythonwifi.flags.IW_EV_LCP_LEN:length])
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 1121, in addEvent
    self.frequency = Iwfreq(data)
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 577, in __init__
    self.frequency = self.parse(data)
  File "/usr/lib/python2.6/site-packages/pythonwifi/iwlibs.py", line 594, in parse
    return float(m)*10**e
OverflowError: long int too large to convert to float

Comment 1 Fabian Affolter 2009-09-16 22:00:12 UTC
On my Fedora 11 i386 system dwscan is working as expected.  I will try to reproduce your traceback on a x86_64 machine.

Comment 2 Fabian Affolter 2009-09-17 07:32:11 UTC
It seems that this error occurs only on x86_64. 

Dominik, did you get this traceback on a i386 system?

Comment 3 Dominik 'Rathann' Mierzejewski 2009-09-17 18:47:26 UTC
The only 32bit machine that I have available has F-10 installed, so this is what dwscan-0.2-3.fc10 says:

$ dwscan
Cmd: 35845
Cmd: 35845
Cmd: 35845
 getScan failure 1 Operation not permitted

If I run it as root, I get:
# dwscan
Cmd: 35845
Cmd: 35845
Cmd: 35845
Traceback (most recent call last):
  File "/usr/sbin/dwscan", line 220, in <module>
    beacon = int(re.match('.*Last beacon: ([0-9]+)ms ago', result.custom[0]).group(1))
IndexError: list index out of range

Comment 4 Dominik 'Rathann' Mierzejewski 2009-11-23 10:21:03 UTC
Any progress? As it is, the application is unusable.

Comment 5 Fabian Affolter 2009-12-24 23:08:50 UTC
There is a new release of python-wifi on the way.  There is a small chance that this will fix some issues because dwscan makes heavy use of python-wifi which is more or less only a wrapper for the Linux Wireless Extensions.  The maintainer of dwscan has no intention to work further on it.  For him dwscan was only a test case.

With atheros based hardware it works fine but there are confirmed problems with newer Intel wireless hardware.


Note You need to log in before you can comment on or make changes to this bug.