Bug 523703 - segfaults when trying to record
segfaults when trying to record
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: recordmydesktop (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Sindre Pedersen Bjørdal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-16 09:50 EDT by Joel Andres Granados
Modified: 2010-01-24 13:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-24 13:33:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace of the failure (25.48 KB, text/plain)
2009-09-16 09:50 EDT, Joel Andres Granados
no flags Details

  None (edit)
Description Joel Andres Granados 2009-09-16 09:50:01 EDT
Description of problem:

[joel@dhcp-lab-139 ~]$ recordmydesktop --no-sound --dummy-cursor black -o test
Initial recording window is set to:
X:0   Y:0    Width:1680    Height:1050
Adjusted recording window is set to:
X:0   Y:4    Width:1680    Height:1040
Your window manager appears to be awesome

Initializing...
Capturing!
Segmentation fault


Version-Release number of selected component (if applicable):
[joel@dhcp-lab-139 ~]$ rpm -qa recordmydesktop
recordmydesktop-0.3.8.1-1.fc11.x86_64

How reproducible:
always


Steps to Reproduce:
1.execute `recordmydesktop --no-sound --dummy-cursor black -o test`
2.Watch it fail.
3.
  
Actual results:
segfault


Expected results:
start recording.

Additional info:
Comment 1 Joel Andres Granados 2009-09-16 09:50:41 EDT
Created attachment 361282 [details]
strace of the failure
Comment 2 William Witt 2009-11-06 21:04:21 EST
I see the same bug, but only when metacity is my wm.  With compiz it doens't crash, but it only takes a frame every 3 seconds.
Comment 3 Bug Zapper 2009-11-16 07:29:21 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jason M. Nielsen 2010-01-08 19:20:48 EST
I also still see this same issue. At time of this posting my Fedora 12 x86_64 desktop was fully updated running compiz. This performance happens regardless of entire desktop, windowid or area selection. 

recordmydesktop-0.3.8.1-1.fc11.x86_64
Comment 5 Till Maas 2010-01-15 05:32:13 EST
I cannot reproduce this with metacity on F12 x86_64. Can you please provide a backtrace and report it upstream?

1) debuginfo-install recordmydesktop
2) gdb recordmydesktop
3) run --no-sound --dummy-cursor black -o test
4) enter: bt
Comment 6 Jason M. Nielsen 2010-01-24 13:08:58 EST
Just wanted to note that with the latest in Fedora 12 x86_64 the performance issues have ceased for the video side of things and I have not seen any segfaults in months. I am seeing issues with recordings when you attempt to record sound which Ive submitted as a different issue. Hopefully thats not the incorrect path to take.

recordmydesktop-0.3.8.1-4.fc12.x86_64

Note You need to log in before you can comment on or make changes to this bug.