Bug 52372 - Bad: $KDEDIR not set
Summary: Bad: $KDEDIR not set
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-23 08:14 UTC by Patrick Cernko
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 06:45:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick Cernko 2001-08-23 08:14:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:0.9.2)
Gecko/20010726 Netscape6/6.1

Description of problem:
Bad: Due to a lack of existence of kdesupport as kde-2.2 package, $KDEDIR
environment variable is not set any more. This leads to not finding the
font dirs of KDE in startkde for example.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. echo $KDEDIR


Actual Results:  There is no output

Expected Results:  Output: /usr

Additional info:

THIS BUG IS FOR kdelibs-2.2!!!

Comment 1 Bernhard Rosenkraenzer 2001-08-23 16:32:00 UTC
KDEDIR is deprecated (it's KDE 1.x cruft actually).

Its usage in startkde is a bug.


Comment 2 Bernhard Rosenkraenzer 2001-08-23 16:34:06 UTC
I agree that quite a few scripts from 3rd party applications still use $KDEDIR 
though. I'll add it back for legacy compatibility, but it'll probably 
disappear for KDE 3.0.



Comment 3 Patrick Cernko 2001-08-24 06:45:21 UTC
It shoud stay as long as any base package (those, witch are released as a "new
kde version", AND probably also koffice, with I doens't see longer included in
the packages for kde-2.2) does require it. So, if for example the default
startkde-script provided by the kde team itself uses the $KDEDIR (or in
startkde-2.2 also the $KDEDIRS) variable, it should been set for the
environment.

Comment 4 Bernhard Rosenkraenzer 2001-08-27 13:34:12 UTC
Fixed in kdelibs-2.2-7



Note You need to log in before you can comment on or make changes to this bug.