Bug 523733 - setroubleshoot: SELinux is preventing /usr/bin/nspluginscan "rename" access on pluginsinfohX1571.new.
Summary: setroubleshoot: SELinux is preventing /usr/bin/nspluginscan "rename" access o...
Keywords:
Status: CLOSED DUPLICATE of bug 523728
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:bf9ba7c9bc2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 14:36 UTC by STEVEN WARD
Modified: 2009-09-16 16:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 16:02:58 UTC


Attachments (Terms of Use)

Description STEVEN WARD 2009-09-16 14:36:40 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing /usr/bin/nspluginscan "rename" access on
pluginsinfohX1571.new.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by nspluginscan. It is not expected that this
access is required by nspluginscan and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c102
                              3
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                pluginsinfohX1571.new [ file ]
Source                        nspluginscan
Source Path                   /usr/bin/nspluginscan
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdebase-4.3.1-2.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.31-3.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31-12.fc12.i686 #1 SMP Mon Sep
                              14 02:27:06 EDT 2009 i686 athlon
Alert Count                   1
First Seen                    Wed 16 Sep 2009 04:49:15 AM BST
Last Seen                     Wed 16 Sep 2009 04:49:15 AM BST
Local ID                      88b27ac6-a7e9-4054-bd2e-176a14f46894
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1253072955.159:50): avc:  denied  { rename } for  pid=1571 comm="nspluginscan" name="pluginsinfohX1571.new" dev=dm-0 ino=393278 scontext=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1253072955.159:50): arch=40000003 syscall=38 success=yes exit=0 a0=9800b98 a1=9800b50 a2=e0610c a3=bfac6e90 items=0 ppid=1513 pid=1571 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="nspluginscan" exe="/usr/bin/nspluginscan" subj=unconfined_u:unconfined_r:nsplugin_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= nsplugin_t ==============
allow nsplugin_t admin_home_t:file rename;

Comment 1 Daniel Walsh 2009-09-16 16:02:58 UTC

*** This bug has been marked as a duplicate of bug 523728 ***


Note You need to log in before you can comment on or make changes to this bug.