Bug 523741 - hald stop in %post, system is not registered to satellite after successful ks
Summary: hald stop in %post, system is not registered to satellite after successful ks
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal
Version: 5.4
Hardware: ia64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Richard Hughes
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 500798
TreeView+ depends on / blocked
 
Reported: 2009-09-16 14:43 UTC by Petr Sklenar ⛄
Modified: 2018-01-22 13:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:21:50 UTC


Attachments (Terms of Use)
post section (4.80 KB, text/plain)
2009-09-16 14:43 UTC, Petr Sklenar ⛄
no flags Details
kickstart for ia64 (15.00 KB, text/plain)
2009-09-16 15:00 UTC, Petr Sklenar ⛄
no flags Details

Description Petr Sklenar ⛄ 2009-09-16 14:43:05 UTC
Created attachment 361289 [details]
post section

Description of problem:
system is not registered to satellite after successful ks, hald stop in %post

Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090820.1 & updated
architecture specific: ia64

How reproducible:
always

Steps to Reproduce:
1. create kickstart rhel54Server ia64
2. system is not registered after successful ks
  
Actual results:
kickstart contains in %post section:
/etc/init.d/messagebus restart
/etc/init.d/haldaemon restart


% post section from /root/ks-post.log
Stopping system message bus: [FAILED]^M
Starting system message bus: [  OK  ]^M
Stopping HAL daemon: [FAILED]^M
Starting HAL daemon: [FAILED]^M

haldaemon is not started in %post for some reason

Expected results:
hal daemon starts in %post

Additional info:
its the same like bug 518342 but hald doesnt start on each ia64 what I tried.

Comment 1 Petr Sklenar ⛄ 2009-09-16 15:00:18 UTC
Created attachment 361297 [details]
kickstart for ia64

Comment 3 Petr Sklenar ⛄ 2009-09-16 17:13:44 UTC
last action written in Satellite kickstart status is
Last File Requested:  	 /Server/Deployment_Guide-en-US-5.2-11.noarch.rpm
kickstart status doesn't recognize that its already finished

and Deployment_Guide-en-US-5.2-11.noarch.rpm was last downloaded package up to /root/install.log

Comment 4 Brandon Perkins 2009-09-16 18:10:44 UTC
So, I did a bunch of testing on this, and found it is unique to ia64, and it
has this behavior for every ia64 system I tried.  As a result, I'm going to say
that this is not a Satellite bug, and instead is either a HAL or Anaconda bug. 
I'm going to flip it to HAL first, and if it needs to go to Anaconda, so be it.
 However, because 5.4 does in fact install (even though it does not register),
the kickstart tree is clean.

[root@test02-ia64 ~]# grep -i hal ks-post.log 
Stopping HAL daemon:                                       [FAILED]
Starting HAL daemon:                                       [FAILED]
Introspect error: The name org.freedesktop.Hal was not provided by any .service
files
Introspect error: The name org.freedesktop.Hal was not provided by any .service
files

Comment 5 Brandon Perkins 2009-09-16 18:22:14 UTC
Please see  Bug 495680 -  CRM #1900142 hald & dbus-daemon stopped in %post of RHEL5 installations for more information.

Comment 6 Richard Hughes 2009-11-12 09:04:00 UTC
(In reply to comment #0)
> % post section from /root/ks-post.log
> Stopping system message bus: [FAILED]^M
> Starting system message bus: [  OK  ]^M
> Stopping HAL daemon: [FAILED]^M
> Starting HAL daemon: [FAILED]^M

This looks to me like the messagebus is crashing soon after start. Does 'dbus-monitor' work after you've restarted messagebus, or does it print a warning?

Also, if dbus is working as expected, can you please attach the complete output of:

killall -9 hald
/usr/sbin/hald --verbose=yes --daemon=no

Thanks.

Richard.

Comment 8 RHEL Product and Program Management 2014-03-07 13:53:11 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 9 RHEL Product and Program Management 2014-06-02 13:21:50 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.