Bug 523776 - Application volume influences global volume
Summary: Application volume influences global volume
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-16 16:15 UTC by Kamil Páral
Modified: 2009-09-16 18:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-16 18:40:55 UTC


Attachments (Terms of Use)
bug demonstration video (208.29 KB, video/ogg)
2009-09-16 16:15 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2009-09-16 16:15:52 UTC
Created attachment 361313 [details]
bug demonstration video

Description of problem:
When setting global volume to some level (say 50%), you can't set application volume to a higher level, because it also raises the global level. See attachment. That is wrong, I may want to have some app louder than all other applications controlled by the global level (and not only current ones, but also all apps run in future).

Version-Release number of selected component (if applicable):
Rawhide 20090915
gnome-media-2.27.91-1.fc12.x86_64
pulseaudio-0.9.17-1.fc12.x86_64

How reproducible:
always

Comment 1 Bastien Nocera 2009-09-16 18:28:22 UTC
It's not wrong, it's the way flat-volumes work.

Comment 2 Lennart Poettering 2009-09-16 18:40:55 UTC
This is not a bug. This is a feature.

The device volume is simply set as an upper boundary of all stream volumes. This simplifies things a lot because per-application volumes are now in the same scale as device volumes. 

Also I don't see why you say this would limit you in anyway. If you want some app do be louder than others, then just set its volume slider that way and you are done.


Note You need to log in before you can comment on or make changes to this bug.