Bug 523791 - smolt database fields too small for filesystem information
smolt database fields too small for filesystem information
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-16 12:55 EDT by Eric Sandeen
Modified: 2009-09-16 13:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-16 13:16:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Sandeen 2009-09-16 12:55:26 EDT
filesystem information for large fs's is getting truncated when it's inserted into the db:

      bsize frsize blocks   bfree      bavail     file       ffree      favail
sent: 4096 4096 5846347456 5846346248 5846346248 4677104128 4677104125 4677104125
rcvd: 4096 4096 2147483647 2147483647 2147483647 2147483647 2147483647 2147483647

this is due to the int(11) types for most of the fields:

+----------+-------------+------+-----+---------+----------------+
| Field    | Type        | Null | Key | Default | Extra          |
+----------+-------------+------+-----+---------+----------------+
| id       | bigint(20)  | NO   | PRI | NULL    | auto_increment | 
| host_id  | int(11)     | YES  | MUL | NULL    |                | 
| mnt_pnt  | varchar(64) | YES  |     | NULL    |                | 
| fs_type  | varchar(16) | YES  |     | NULL    |                | 
| f_favail | int(11)     | YES  |     | NULL    |                | 
| f_bsize  | int(11)     | YES  |     | NULL    |                | 
| f_frsize | int(11)     | YES  |     | NULL    |                | 
| f_blocks | int(11)     | YES  |     | NULL    |                | 
| f_bfree  | int(11)     | YES  |     | NULL    |                | 
| f_bavail | int(11)     | YES  |     | NULL    |                | 
| f_files  | int(11)     | YES  |     | NULL    |                | 
| f_ffree  | int(11)     | YES  |     | NULL    |                | 
| f_fssize | bigint(24)  | YES  |     | NULL    |                | 
+----------+-------------+------+-----+---------+----------------+

All but f_bsize and f_frsize should likely be increased to bigint(24) to accomodate larger filesystems.

Thanks,
-Eric
Comment 1 Mike McGrath 2009-09-16 13:16:50 EDT
Ok, I think this is fixed upstream.  It didn't require downtime like I thought it might.  Only took about 30-40 seconds per column to update.

Note You need to log in before you can comment on or make changes to this bug.