Bug 523792 - Fedora 12 Alpha install is missing an initrd
Fedora 12 Alpha install is missing an initrd
Status: CLOSED DUPLICATE of bug 519350
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-09-16 12:56 EDT by Joshua Rosen
Modified: 2009-10-06 09:05 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-06 09:05:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
virt-inspector output (69.11 KB, text/plain)
2009-09-21 10:43 EDT, Joshua Rosen
no flags Details

  None (edit)
Description Joshua Rosen 2009-09-16 12:56:41 EDT
Description of problem: I installed a 32 bit and a 64 bit F12 Alpha VM on KVM running on a Fedora 11 host. I can't do the initial boot of either VM, I'm getting a kernel panic on the VM. I've attached the messages from /var/log/messages.


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1.Install F12 Alpha, virtual disk is mounted as virtio
2.Try and boot it
3.
  
Actual results:

Get a kernel panic when booting the F12 Alpha

Sep 16 12:43:15 localhost kernel: device vnet3 entered promiscuous mode
Sep 16 12:43:15 localhost kernel: virbr0: topology change detected, propagating
Sep 16 12:43:15 localhost kernel: virbr0: port 2(vnet3) entering forwarding state
Sep 16 12:45:51 localhost kernel: virbr0: port 2(vnet3) entering disabled state
Sep 16 12:45:51 localhost kernel: device vnet3 left promiscuous mode
Sep 16 12:45:51 localhost kernel: virbr0: port 2(vnet3) entering disabled state
Sep 16 12:45:56 localhost kernel: device vnet3 entered promiscuous mode
Sep 16 12:45:56 localhost kernel: virbr0: topology change detected, propagating
Sep 16 12:45:56 localhost kernel: virbr0: port 2(vnet3) entering forwarding state
Sep 16 12:48:59 localhost kernel: virbr0: port 2(vnet3) entering disabled state
Sep 16 12:48:59 localhost kernel: device vnet3 left promiscuous mode
Sep 16 12:48:59 localhost kernel: virbr0: port 2(vnet3) entering disabled state
Sep 16 12:49:19 localhost libvirtd: 12:49:19.285: error : Policy kit denied action org.libvirt.unix.manage from pid 4423, uid 500, result: no#012



Expected results:


Additional info:
Comment 1 Mark McLoughlin 2009-09-21 09:08:47 EDT
(In reply to comment #0)
> I can't do the initial boot of either VM, I'm getting a kernel panic on the VM.

What exactly is the kernel panic in the VM?

What versions of libvirt, qemu-kvm etc.?

What's in ~/.virt-manager/virt-manager.log and /var/log/libvirt/qemu/$guest.log

See http://fedoraproject.org/wiki/Reporting_virtualization_bugs

(In reply to comment #0)

> Sep 16 12:49:19 localhost libvirtd: 12:49:19.285: error : Policy kit denied
> action org.libvirt.unix.manage from pid 4423, uid 500, result: no#012

This looks like a separate issue from a guest kernel panic
Comment 2 Joshua Rosen 2009-09-21 09:28:27 EDT
The kernel panic is 

Not syncing : VFS: Unable to mount root fs on unknown block (0,0)

Here is the log file,

[Mon, 21 Sep 2009 09:21:36 virt-manager 27038] INFO (virt-manager:144) Application startup
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (engine:81) About to connect to uris ['qemu:///system']
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:145) Bonding masters are: []
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:171) Got physical net device /org/freedesktop/Hal/devices/net_02_cd_f9_c4_24_f9
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:231) Adding net device vnet4 02:cd:f9:c4:24:f9 /sys/class/net/vnet4 (bridge: br0)
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:203) Checking for VLANs on /sys/class/net/vnet4
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:171) Got physical net device /org/freedesktop/Hal/devices/net_8e_9a_11_62_9f_0d
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:231) Adding net device vnet5 8e:9a:11:62:9f:0d /sys/class/net/vnet5 (bridge: br0)
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:203) Checking for VLANs on /sys/class/net/vnet5
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:171) Got physical net device /org/freedesktop/Hal/devices/net_fe_b4_9b_2b_98_b7
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:231) Adding net device vnet3 fe:b4:9b:2b:98:b7 /sys/class/net/vnet3 (bridge: virbr0)
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:203) Checking for VLANs on /sys/class/net/vnet3
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:171) Got physical net device /org/freedesktop/Hal/devices/net_3e_62_af_f9_c4_9f
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:231) Adding net device virbr0 3e:62:af:f9:c4:9f /sys/class/net/virbr0 (bridge: None)
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:203) Checking for VLANs on /sys/class/net/virbr0
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:171) Got physical net device /org/freedesktop/Hal/devices/net_06_a7_ba_3f_78_27
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:231) Adding net device pan0 06:a7:ba:3f:78:27 /sys/class/net/pan0 (bridge: None)
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:203) Checking for VLANs on /sys/class/net/pan0
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:171) Got physical net device /org/freedesktop/Hal/devices/net_computer_loopback
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:231) Adding net device lo 00:00:00:00:00:00 /sys/class/net/lo (bridge: None)
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:203) Checking for VLANs on /sys/class/net/lo
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:171) Got physical net device /org/freedesktop/Hal/devices/net_00_50_8d_95_a8_e6_0
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:231) Adding net device br0 00:50:8d:95:a8:e6 /sys/class/net/br0 (bridge: None)
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:203) Checking for VLANs on /sys/class/net/br0
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:171) Got physical net device /org/freedesktop/Hal/devices/net_00_50_8d_95_a8_e7
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:231) Adding net device eth1 00:50:8d:95:a8:e7 /sys/class/net/eth1 (bridge: None)
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:203) Checking for VLANs on /sys/class/net/eth1
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:171) Got physical net device /org/freedesktop/Hal/devices/net_00_50_8d_95_a8_e6
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:231) Adding net device eth0 00:50:8d:95:a8:e6 /sys/class/net/eth0 (bridge: br0)
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:203) Checking for VLANs on /sys/class/net/eth0
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (engine:320) window counter incremented to 1
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:455) Scheduling background open thread for qemu:///system
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:585) Background thread is running
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:623) Background open thread complete, scheduling notify
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:632) Notifying open result
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (connection:637) qemu:///system capabilities:
<capabilities>

  <host>
    <cpu>
      <arch>x86_64</arch>
    </cpu>
    <topology>
      <cells num='1'>
        <cell id='0'>
          <cpus num='2'>
            <cpu id='0'/>
            <cpu id='1'/>
          </cpus>
        </cell>
      </cells>
    </topology>
  </host>

  <guest>
    <os_type>hvm</os_type>
    <arch name='i686'>
      <wordsize>32</wordsize>
      <emulator>/usr/bin/qemu</emulator>
      <machine>pc</machine>
      <machine>isapc</machine>
      <domain type='qemu'>
      </domain>
      <domain type='kvm'>
        <emulator>/usr/bin/qemu-kvm</emulator>
      </domain>
    </arch>
    <features>
      <pae/>
      <nonpae/>
      <acpi default='on' toggle='yes'/>
      <apic default='on' toggle='no'/>
    </features>
  </guest>

  <guest>
    <os_type>hvm</os_type>
    <arch name='x86_64'>
      <wordsize>64</wordsize>
      <emulator>/usr/bin/qemu-system-x86_64</emulator>
      <machine>pc</machine>
      <machine>isapc</machine>
      <domain type='qemu'>
      </domain>
      <domain type='kvm'>
        <emulator>/usr/bin/qemu-kvm</emulator>
      </domain>
    </arch>
    <features>
      <acpi default='on' toggle='yes'/>
      <apic default='on' toggle='no'/>
    </features>
  </guest>

  <guest>
    <os_type>xen</os_type>
    <arch name='i686'>
      <wordsize>32</wordsize>
      <emulator>/usr/bin/xenner</emulator>
      <machine>xenner</machine>
      <domain type='kvm'>
      </domain>
    </arch>
    <features>
      <pae/>
      <nonpae/>
      <acpi default='on' toggle='yes'/>
      <apic default='on' toggle='no'/>
    </features>
  </guest>

  <guest>
    <os_type>xen</os_type>
    <arch name='x86_64'>
      <wordsize>64</wordsize>
      <emulator>/usr/bin/xenner</emulator>
      <machine>xenner</machine>
      <domain type='kvm'>
      </domain>
    </arch>
    <features>
      <acpi default='on' toggle='yes'/>
      <apic default='on' toggle='no'/>
    </features>
  </guest>

</capabilities>

[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (manager:495) About to append vm: xp
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (manager:495) About to append vm: f12_32
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (manager:495) About to append vm: helldiver
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (manager:495) About to append vm: f12_64
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (manager:495) About to append vm: hellcat
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (manager:495) About to append vm: Win2K
[Mon, 21 Sep 2009 09:21:38 virt-manager 27042] DEBUG (manager:483) VM helldiver started
[Mon, 21 Sep 2009 09:21:47 virt-manager 27042] DEBUG (engine:491) Starting vm 'f12_64'.
[Mon, 21 Sep 2009 09:21:48 virt-manager 27042] DEBUG (connection:171) Got physical net device /org/freedesktop/Hal/devices/net_52_ae_8c_fb_57_b9
[Mon, 21 Sep 2009 09:21:48 virt-manager 27042] DEBUG (connection:231) Adding net device vnet0 52:ae:8c:fb:57:b9 /sys/class/net/vnet0 (bridge: virbr0)
[Mon, 21 Sep 2009 09:21:48 virt-manager 27042] DEBUG (connection:203) Checking for VLANs on /sys/class/net/vnet0
[Mon, 21 Sep 2009 09:21:48 virt-manager 27042] DEBUG (manager:483) VM f12_64 started
[Mon, 21 Sep 2009 09:21:55 virt-manager 27042] ERROR (details:257) Cannot initialize notification systemorg.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
[Mon, 21 Sep 2009 09:21:55 virt-manager 27042] DEBUG (details:1266) Trying console login
[Mon, 21 Sep 2009 09:21:55 virt-manager 27042] DEBUG (details:1279) Graphics console configured at vnc://127.0.0.1:5900
[Mon, 21 Sep 2009 09:21:55 virt-manager 27042] DEBUG (details:1292) Starting connect process for 127.0.0.1 5900
[Mon, 21 Sep 2009 09:21:55 virt-manager 27042] DEBUG (details:985) Nothing selected.
[Mon, 21 Sep 2009 09:21:55 virt-manager 27042] DEBUG (details:985) Nothing selected.
[Mon, 21 Sep 2009 09:21:55 virt-manager 27042] DEBUG (engine:320) window counter incremented to 2
[Mon, 21 Sep 2009 09:21:55 virt-manager 27042] DEBUG (details:1266) Trying console login
[Mon, 21 Sep 2009 09:21:55 virt-manager 27042] DEBUG (details:1279) Graphics console configured at vnc://127.0.0.1:5900
[Mon, 21 Sep 2009 09:21:55 virt-manager 27042] DEBUG (details:1292) Starting connect process for 127.0.0.1 5900
[Mon, 21 Sep 2009 09:21:55 virt-manager 27042] DEBUG (details:1188) VNC initialized
Comment 3 Mark McLoughlin 2009-09-21 10:03:30 EDT
I'm not sure this is a F11 host KVM issue, I think it's more like an F12 guest issue

Could you attach the full guest kernel output ? e.g. boot the guest and in the grub menu, hit 'e' and remove the 'rhgb quiet' bit from the command line and add 'console=ttyS0'

Then run 'virsh console <guest>' and save the output

Is there an initrd line in the guest's grub.conf?
Comment 4 Mark McLoughlin 2009-09-21 10:05:48 EDT
The output of running virt-inspector on the guest image might shed some light on things too
Comment 5 Joshua Rosen 2009-09-21 10:43:54 EDT
Created attachment 361952 [details]
virt-inspector output
Comment 6 Mark McLoughlin 2009-09-21 11:06:04 EDT
Yep, that confirms it:

Grub entry Fedora (2.6.31-12.fc12.x86_64) does not specify an initrd at /usr/lib64/perl5/vendor_perl/5.10.0/x86_64-linux-thread-multi/Sys/Guestfs/Lib.pm line 1577.

I'm guessing this is a problem with /sbin/new-kernel-pkg or something, and I'm pretty sure there's already a bug on this but, just in case, I'm adding it to the F12Blocker bug
Comment 7 Joshua Rosen 2009-09-21 11:43:56 EDT
Don't the people who are building the F12 Alpha try it on KVM before they try it on real hardware? Now that KVM is in a usable state I would think that step 1 would always be to run in on KVM, then if it works try it on real hardware.
Comment 8 Mark McLoughlin 2009-09-21 11:59:59 EDT
Joshua: there's nothing KVM specific about this; several people have seen it on bare-metal machines
Comment 9 Hans de Goede 2009-10-06 09:05:16 EDT
This is a dup of 519350, see that bug for more explanation of what is going on here.

*** This bug has been marked as a duplicate of bug 519350 ***

Note You need to log in before you can comment on or make changes to this bug.