Bug 523795 - yum removes old kernel even if it can not install new kernel
yum removes old kernel even if it can not install new kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-09-16 13:18 EDT by Nicolas Mailhot
Modified: 2014-01-21 18:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 00:27:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2009-09-16 13:18:38 EDT
Description of problem:

As part of trying to keep a limited number of kernel packages on system, yum will remove an old kernel every time it installs a new one (in cruise mode)

The problem is, it will do so even if it decided it won't install the new kernel after all


Paquets omis en raison de problèmes de dépendances :
    dracut-kernel-001-9.git6f0e469d.fc12.noarch depuis rawhide
    kernel-2.6.31-17.fc12.x86_64 depuis koji-f12-builds

Dépendances résolues

================================================================================
 Paquet                          Architecture
                                        Version           Dépôt           Taille
================================================================================
Mise à jour:
...
Suppression:
 kernel                          x86_64 2.6.31-2.fc12     installed        79 M
Omis (problèmes de dépendances):
 dracut-kernel                   noarch 001-9.git6f0e469d.fc12
                                                          rawhide         4.7 k
 kernel                          x86_64 2.6.31-17.fc12    koji-f12-builds  18 M


Version-Release number of selected component (if applicable):

yum-3.2.24-4.fc12.noarch
Comment 1 seth vidal 2009-09-16 13:24:55 EDT
Can you include the full output and run yum with the -d9 option?

thanks.
Comment 2 Nicolas Mailhot 2009-09-16 14:46:03 EDT
not really, yum decided not to install the new rawhide kernel package because it depended on rawhide dracut packages, that were not installable because of a conflicting dracut package the dracut people had asked me to test (was supposed to shed light on the boot over md failures). However it had already marked one kernel for deletion and did delete it during the transaction.

Well to cut things short the experimental dracut ended in total crap and I'm rebuilding this system raid right now. So the system is not available for testing (hope I won't lose a month of data). You can simulate by doing a rpm -e --nodeps of dracut* and installing the latest dracut package harald scratch-built in koji
Comment 3 James Antill 2009-09-17 00:27:49 EDT
Right, so skip-broken removed the install part but not the remove part. I'm going to say this is NaB. You still have the current kernel, there are a couple of ways to keep extra kernels about ... the fact installonly_limit removed an old one to make room, which wasn't needed isn't really the same as a real dep.

Note You need to log in before you can comment on or make changes to this bug.